Middle click toggle to other pane in v12.26

  • w7 x64 updated from v.12.23 to v.12.24 works - then to v.12.26 = NOT work

Prefs > File Displays > Mouse > Command: Go TABMOVE=active Set SOURCE=Toggle

*Single middle click the background pane doesn't work as before -
however, all other middle clicks function as expected.

  • Even double middle-click does not work when relevant selections are checked/unchecked.

  • Changing mouses (mice) does not correct this behaviour.

Confirmed by careful Drive Snapshot re-imaging to v.12.23 where it works,
combined w/ System Restores & confirmation of successful behaviours in v.12.24.

** ALSO -- I'm NOT able to dLoad any previous versions from the official page here:

    • dL any previous version actually gives v.12.26 as confirmed by Properties > Details

?? Do y'all intend this ? or ..... ?

I did not have a copy of previous v.12.25 to test, so I wanted to dL that version
to have in my local archive for testing/reversion.

Thank You for your Help

Is that a single-line command? It doesn't make any sense, since it's trying to run both the Go and Set commands on a single line.

There was a bug in older versions where it would mis-parse some invalid commands and allow them to run (sometimes with unexpected results), which is probably why it "worked" before. But the error here is the command is simply wrong.

Try Set SOURCE=Toggle by itself if the aim is to switch which side is active.

Or Go TABMOVE=active by itself if the aim is to move the active tab to the other side.

thx Leo - I see you just ammended your reply as I was about to refer you back
to your earlier solution for me:

Yes, currently " Go TABMOVE=active " does what I want - moves the currently Active tab
to the other pane, and switches to it.

OK - just now installed v.12.26 and works as desired - Thanks very much!

  • Finally - what is the Policy on previous 'sub-version' downloads? (12.23 - 12.24 - 12.25, etc)

The command in my other post would only work in contexts where you can enter a multi-line command. To use the same thing on that mouse action, you'd need to create a User Command with the two lines inside it, then run that from the mouse action.

Shouldn't be needed if Go TABMOVE=active works on its own.

There is no real "policy". Download links in release notes all point to the same place, if you check the URLs. (Beta versions point to a different place, and we also have installers online for people using older versions, e.g. Opus 11.)

If you want an older Opus 12 installer, we can put them online for you, but it's better to fix whatever is wrong than stay on an out of date version forever and stop updating. You can also keep the previous installer yourself, of course, which is good practice in general with all software. (Well, except software with "installers" that don't include the program and download it from a website every time you run them, but we don't do or like that.)

yes - I experienced that when I tried to separate the 2 commands whilst in Prefs!
It's all working beautifully again.

I figured that was dOpus policy - Keep the ship (■■■■e) CLEAN as you go!
Pride of Craftsmanship and all that.

I've enjoyed learning from the YouTube vids you've done w/ Jean L. & Joe G. -
hope y'all continue w/ more ~

1 Like

Planning to do more videos when less busy. Trying to finish some projects first without losing momentum.