Missing drive buttons

I've recently re-discovered Dopus, having used it on an Amiga in the distant past so I'm a novice. It was working as I wanted it to until it updated a couple of days ago.
Since the udate to, I can't find a way to show the drive buttons in the "drives" toolbar. After a few hours messing about they finally appeared in a drop-down menu on the "Fixed Drives" icon. However, no other drives are showing, i.e. USB drives or CD drives with disks in.

I've got a work-around by saving a Lister theme of "(My) Computer" in the left and right hand panels but this is far from ideal.

If this cannot be resolved, is it possible to revert to the earlier version of Dopus and maybe stop any future updates

The first code sequenz represents the fixed drives, the second on the CD & removable ones.
So you can set up two separate sections for each type of drives.

Go DRIVEBUTTONS=cdrom,network,removable,hideempty

You can also use +/- for hiding or showing particular drives, for example


would hide drives C & D, while using the plus sign would show only those listed
after the plus character, like


Thanks, but as I said I'm a novice. Where do I type (paste) the commands you recommend? I think there was a "Go" button on the top toolbar but if it was there, it 's gone! I've looked in the Commands list but it's not there.
I should have said that there are two icons on the drive toolbar, Fixed Drives and Other Drives. My Fixed Drives are there on a drop-down menu but my other drives, USB, MP3 Player and CD drives with disks inserted are not showing apart from in "Computer".

It's not clear to me exactly what you've got or what you want.

Can you post a screenshot showing what the toolbar currently looks like?

I'm sorry if I've been unclear, (the curse of the Newbie?). My problem is as follows: Before the update, my all of my drives that were actively connected showed on the "Drives" Toolbar

I could see all of the drive letters of the Fixed drives C, D, I, J, O, P. Also were the drive letters for my DVD players (if there was a disk in) E & K. Any USB or MP3 player that was connected was in the "Drives" Toolbar, I'd given them the following drive letters, F, W, X.

Since the update there are only two icons in the "Drives" Toolbar, which are called "Fixed Drives" and "Other Drives". If I click on the "Fixed Drives" icon, I get a drop-down list of my fixed drives, C, D, I, O, P. I could live with this even though I prefer to have the drive letters instantly available and not in a sub-menu.

However, when I click on the "Other Drives" icon, none of my other drives show! Even though I have disks inserted in the DVD players they do not appear, as don't any USB stick or MP3 player.

Sorry, I can't find a way to attach a screen grab, I tried pasting it into a Word Doc but it wasn't allowed.

Any help will be appreciated

I doubt that was caused by the update as the drives toolbar and related commands shouldn't have been changed in it (and are still the same here).

It sounds like you've been editing the toolbar and accidentally turned the buttons into menus.

Here's the original version of the drives toolbar:
Drives.zip (550 Bytes)

[ul][li]Extract the zip file to somewhere.

[li]Go to Settings -> Customize Toolbars -> Toolbars and delete your existing Drives toolbar. (Keep the Customize window open.)

[li]Double-click the Drives.dop file that was inside the zip. (The Drives toolbar will re-appear in the list of toolbars, and it'll also open in a floating window.)

[li]Select the Drives toolbar in the Customize window, then turn off the Floating toolbar checkbox on the right.

[li]Click OK to close the Customize window.[/li][/ul]

Watta Guy you are Leo.

I don't know how close you are to Cumbria but you may have heard my cheer when your solution worked.

Thanks again,

With credit to Steje Backup your configuration before making changes!.

As I said in my first post, the last time I used Dopus was about 20 years ago on a different machine (Amiga) so I'm a novice. Even back then I didn't change much of the configuration and as Leo said, I must have changed it by accident as I don't mess about with it too much.

I am such a novice that I didn't KNOW that I could back-up the configuration, but thanks to Bob mentioning it, I have now. Who knows, I may even try delving deeper into Dopus now that I can restore it back to how it was.

Many thanks to all who posted, it was much appreciated.

Best regards,

Al Palmer

I have the same problem bigal02 has had. I’m using Dopus 10.05 (upgraded from version 9), and on the Drives toolbar, I can see all of the drive letters/icons for the hard drives (internal C & D and external N & O), but the drive letters/icons for the CD/DVD drives (E & F) do not show up on the (1) Drives toolbar and (2) Folder Tree. I have an near new HP desktop with Windows 7 (64bit). I tried Leo’s recommendation of using “Drives.zip” to reinstall the Drives toolbar, but nothing changed on the toolbar.

I have figured out a workaround. To add the “E” CD/DVD drive to the Drives toolbar:

 ●	Skip this step if the “E” CD/DVD drive shows on the Folder Tree.

     In the “Location” on the “Location” toolbar, enter “E:\” and press <enter>.  This temporarily adds the “E” CD/DVD drive to the Folder Tree.

 ●	Go to Settings -> Customize Toolbars

 ●	Drag the “E” CD/DVD drive icon from the Folder Tree to the Drives toolbar, just to the right of the other icons.

 ●	Close the Customize Toolbars window.

This worked for me so that the “E” CD/DVD drive letter/icon stays on the Drives toolbar; however, the next time I start Dopus, the temporary “E” CD/DVD drive letter/icon does not appear the Folder Tree.

You probably just need to remove the "hideempty" argument from the second set of drivebuttons, and turn off the similar options in Preferences for the Folder Tree and the Computer virtual folder.

The underlying issue is probably that the CD/DVD drives are not correctly reporting when media is inserted and ejected. We have some changes planned to slightly improve how Opus handles drives/drivers which don't reliably report the change, but for some drives you'll probably still need to configure Opus to show them all the time, whether they report their status as empty or not.

Thank you very much, Leo. You win the cupie doll. Removing the "hideempty" argument from the second set of drivebuttons, and turning off the similar options in Preferences for the Folder Tree and the Computer virtual folder completely solved the problem. :smiley: