GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Mozy Backup causing slow folder reads in Explorer and Opus


#1

Hi,

since yesterday, my Directory Opus is very very slow for folders browsing … Every new folder i want to access takes around 10s of DOpus using 100% CPU !

I presume it’s not Dopus’ fault because it has never happened to me but i just want an idea about what to check to understand what is happening

I have not installed anything yesterday, i have checked my drives and they seem ok, and, (the worst), everything works fine and fast with my good old Power Desk (explorer-like) i have launched again to test.

So is there a directory opus log or a place where i could see what could happen ? and, is there a way to reset all dopus settings in order to check if it’s a bad setting which causes this problem

Thanks


#2

Try these steps:
[Crash, exit or high CPU when viewing certain directories)


#3

Thanks Leo : i had already tried the things explained there :

No specific files or folders … they can contain pictures or music or whatever else
No alcohol, disabled Use Shell Image extraction, disabled all viewers plugins

But then i have read this one :
[General slowdown or instability investigation steps)

Thumbnail caching have been purged and disabled
I had no mapped/network drive
I have turned on Generic icons for all folders

When i have done that, it worked better : the problem would not occur on all folders… still strange …

But then i tried W0lfdale’s suggestion [Slow response on all listers)
and found Mozy was the bad one … it seems the new version of Mozy Backup is trying to check each file of each folder to tell if it has been backed up or not by changing the icon … quite mad idea because it’s very slow !

I have disabled it and it works real fine … In Mozy, you need to check “Disable icon overlay in explorer”

Thanks for your FAQ Leo !


#4

Thanks for reporting that back. The info should help other people.

BTW, does the same thing happen in Explorer? I think Opus and Explorer request the icons in very similar ways, FWIW.


#5

Leo, yes Explorer was also really slow … I thought it was a hard drive problem but after having tried to access my drives with Ubuntu or Power Desk, i had seen it was not the disks’ fault.

This new Mozy feature is really really disturbing, if you want more information about it for your FAQ or for reporting to Jon and Greg, tell me (or maybe i should report it to them)


#6

Thanks. I think you’ve already posted all the needed info.

Hopefully, since it affects Explorer and thus a lot of people, it’ll get fixed in a Mozy update. My fear was that it only affected Opus and might be overlooked by them.

I’ve renamed the thread so people using Mozy will be more likely to notice it.


#7

Just a confirmation for others that with virtually the identical problem, making the suggested change in Mozy immediately fixed the problem for me. I DID NOT see the same slow response in Windows explorer, just DOpus. I too thought I had a hard drive problem. However, accessing the drive mapped from another PC showed no slowdowns.

It had been bugging me for days, and all kinds of other things suggested elsewhere made no difference. BTW, I’ve been running Mozy for months, and it’s been a good while since the last update. Problem just start about 2 weeks ago.


#8

Thank you, thank you, thank you!

DOpus was driving me crazy as it was taking so long to browse folders and nothing seemed to speed it up.

Then I found this and bingo!

Thank you!


#9

Since this still seems to be a problem in Mozy Backup (affecting Explorer as well as Opus for some people), if you’ve been affected by it please do report it to the makers of Mozy Backup (if you haven’t already) so that they can fix the problem. Seems like they are doing too much processing (or operations which could potentially wait a long time) when generating icons which should be a near instant procedure.

If they need any help debugging things on the Opus side then I’d be happy to help (or they could get in touch with GPSoftware).