MP3 Tag Editing plugin (Obsolete: Use the Metadata panel now)

You can ask here, but if might be forgotten about. If you ask here instead it'll go into the requests database.

I updated the mp3 plug-in to 2.0.0.2 as I thought that as well as fixing the tag viewer issue it may have fixed a play issue I just noticed today, but, it hasn't. The issue:

I have one mp3 collection that can be played in all my players, but, DOpus will not play a single track. I did not convert the files to mp3 myself so thought it may be a Header issue so used Foobar2000 to rebuild the Headers which normally works, but, it did not resolve the play issue. I had successfully burned all these mp3 files to CD in CDA format to play on anything so just experimented by ripping that CD to mp3 again at 256 kbps 44 kHz which was the same bit rate as the original mp3 files and found they would not play in DOpus either. I then ripped the CD again to mp3 at 224 kbps and they would play in DOpus. Trying again at 320 kbps playing in DOpus fails again. These are all non VBR files. All mp3 VBR files seem to play in DOpus including one I found at 257 kbps VBR and ones at higher bit rates.

I'm not sure where the issue begins, but, it seems all non VBR mp3 files of 256 kbps and over will not play in DOpus.

Anyone else seeing this?

Does Windows Media Player play the files?

Yes, all the tracks play in Windows Media Player and also in Foobar2000 and Real Player.

Since you have three programs that can play them, may I suggest you use them? Opus is a file manager, not a music player :slight_smile:

Also, updating DOpus to 9.0.0.7 which includes mp3 plugin 2.0.0.3 doesn't solve the issue either.

Well yes, I know that and do so, but, it is often convenient to play an mp3 track in DOpus to check out if it's the correct one for managing without having to fire up a player so I thought I'd report the issue which is an odd one. :unamused:

Hi,
I'm new with Opus. I'm trying out Opus 9.5
Is it possible to play MP3s with Opus?
Thanks
Samito

Yes, see the FAQ, HOW TO: Enable/fix playback of various media formats in Opus, near the bottom under How to make MP3, WMA and WAV play in the viewer pane.

Got it, many thanks :smiley:
Samito

I have DO 11 and it used to play .mp3 files in the viewer, but that no longer works. I cannot remember if I installed a plug or not, but the only plugin that I see for audio is one called Audio Tags. It lists about 10 extensions that it supports and none of them is .mp3.

Is there another plugin I should be using.

Thanks.

This thread still applies: Audio and mpg won't play in Viewer

Thanks. I did everything I can think of to fix the mp3 playing. The default app for mp3 is Windows Media player. And I just installed this codek pack


and rebooted, but DO still doesn't play them in the viewer pane. If I dbl click an mp3 it plays in Windows Media Player. So I don't know what else to look at..

PS:
When I right-click on the Windows Media Player that is in the Viewer Pane and select Error Details from the menu, it says:

Windows Media Player cannot find the file. ...

Hey, I just copied the mp3 to the root of the drive, RENAMED IT and selected it, and IT WORKED!

The file name was: '66_23 Troggs - Wild Thing.mp3'. I renamed it to Thing.mp3, and that worked! I renamed it back and it no longer worked. So I renamed the one in the original folder(F:\Music\1966 - 71 Music) to Thing.mp3 and that did not fix it.

So, it seems like it doesn't like the longer filename or folder name. Or it doesn't like special characters?
Is this a 32bit vs 64bit thing? That codek that In installed said it had the splitter things. And said it fixed 95% of all problems.

That sounds like an issue with Windows 10 turning off short filenames by default, which has in turn caused problems with Windows Media Player's ActiveX control because it needed short file names to work around other issues.

This slipped off the radar but I'll see if we can get that fixed / worked around. Thanks for the reminder. This was fixed a while ago in Opus 12.

When I renamed the mp3 that I copied to the root of the drive to xxxxxxxxxxxxxxxxxxxxxxxThing.mp3 it also played fine in OD. And then I renamed it to 'Wild Thing.mp3' and it would not play at the root. So, do you still think that is an 8.3 short filename issue? 8.3 standard is not just the length of the filename is it? It also doesn't accept anything except a-z, 0-9, and _, correct?

I have OD 11, so would that also be fixed if you fixed it? Or just OD12?
Wish there was a way that I could fix it..

Windows Media Player's ActiveX component has problems with spaces in names, which short names were used to work around. So it's the space, not the length.

Updates will only be for Opus 12 at this point.

Ok. Thanks for your help.

I went to fix the problem with Windows Media Player and spaces in filenames on new Windows 10 installs (with short names disabled), only to find I already had fix it.

It has been fixed in Opus 12 for a while, in fact (Opus 12.0.5). I remembered the problem, but not fixing it. :slight_smile:

where is the software URL? download link?

The MP3 plugin was for editing MP3 tags in the viewer window. It was included in older versions of Opus.

It's no longer included as that functionality was replaced by the metadata panel.

If you just want to play mp3 files, the ActiveX plugin should handle that via the Windows Media Player preview handler (click to play) or activex control (auto-play).