MP4 - Always a black video thumbnail

I know this applys to Windows Explorer since Dopus basically displays what Explorer.exe does but I figured maybe someone can help out here, if they are savvy with video codecs

Basically the issue is that all videos which are H.264 MP4 (.mpeg), the video thumbnail preview is always a black screen.

The same video in WMV format (with x2 larger file size, but same video quality) does show something other than a black screen.

Is this normal for H.264 MP4 encoded files, or is there a fix/codec I can install to fix this issue.

Did you check Settings -> viewer plugins -> movie? There is an option to skip black frame, you can also tune that option.

Thank you very much, that works!

For anyone who also comes across this, here is what I did:

  1. Settings (mnu) --> Viewer Plugins --> Movie --> Configure...
  2. Check: Skip over inital black frames (I just left the "Black threshhold" at 95... I am not really sure what it does anyway)
  3. Then I refreshed the thumbnails - For this I created a hotkey (Ctrl+~) which executes this command: REFRESHTHUMBS - I talk about this here [Folder Thumbnails - Prefer Images Option?)

Okay, I also found that 200 is a good threshhold for all or most MP4s.
I guess it is how far into the movie dopus will take the thumbnail of.

One other note:
Even when you update the thumbnails for a parent folder and they display fine in the subfolder's thumbnail (from within the parent),
you must still refresh the thumbnails for each subfolder you enter, so that they do not appear black in there also. (so that is why it is nice to have a hotkey to do it)

You can wipe the entire thumbnail cache if you want all of them to be recalculated. (Prefs - Lister Display Modes - Thumbnails.)

A good idea as well.
Thanks leo!

I just encountered this again today in Win7, and I found a new fix for it.

I noticed that Dopus was using Haali after installing the K-Lite codec pack (I tried both: Basic and Standard). It was using the splitter to generate thumbnails for .MP4 files, in which case they would always be black, regardless of the Dopus settings related to the black threshold and seconds offset,

The behavior:

  • Dopus was generating the actual thumbnails for only .wmv files.
  • For .mp4 files, Dopus was generating a black thumbnail
  • Explorer.exe was able to generate thumbnails for both, properly,

The fix:

  1. Start --> All Programs --> K-Lite Codec Pack (folder) --> Codec Tweak Tool (folder) --> All Options
  2. Manage source filters (btn) --> .MP4 (group) --> Changed from "Haali (recommended)" to "System default

This setting for "source filters" basically told Dopus to use Haali, which was causing the black thumbnail.
Explorer didn't bother using this setting and used the "system default" as-is, so that is why it worked.
As soon as changing this setting, and having Dopus refresh a previously cached folder's [black] thumbnails (using my custom hotkey: Ctrl + ~), Dopus then generated them like explorer.exe, and without Haali popping up in the system tray (hence not using it any longer)

Just thought I would share this tip for everyone. Hope it was helpful.
Best regards.