MTP in 2018 now 2019

Another thing that can mess up MTP transfers is if you have the ADB interface enabled on the phone. I've found that turning this off really helps.

Thanks Paul.

On my phone it's called USB debugging. I am a developer and therefore I need this enabled. I have no ADB setting.

Bottom line, two other programs (Explorer and Beyond Compare) get this to work with this setting enabled. My phone runs Android One so there is no extra $%#@ to interfere.

This problem is specific to Opus for me.

If you have USB debugging enabled, then you have ADB enable - it's one and the same thing. I run a custom ROM too; LineageOS or currently, crDroid. I've had Opus running with ADB enabled but I find it tends to be a bit flakey, so I turn ADB off. I don't use Explorer for file transfers so can't really comment whether it's any better than Opus. It maybe that Opus' implementation of MTP is slightly different to Microsoft's. In my experience, GP Software tend to have a better grip on the various protocols and implementations than Microsoft does anyway.

Opus uses Microsoft's implementation, the same as Explorer. The problem is that MTP is garbage at both ends (phone and PC) and e.g. can lock up if you try to access two files at once.

OTOH, FTP generally just works and is quick and easy to set up on Android.

With ADB/USB debugging turned off I don't have any problems with MTP on Opus. Agreed it's not the best for file transfers, but if you queue up files from different folders it runs just fine rather trying to force multiple file transfers

Just tested MTP in Directory Opus 12.15.1. Fixed my problems on my Nokia 8 (Android 9).


I second that!
12.15.1. MTU update is awesome! Yesterday i managed 100Gb of files on my phone (Galaxy S7 edge) without any issue, delay, freeze or force-close. Didnt have to touch Explorer at all!
Thank you Devs!


Thanks for your feedback!

The change we made had an unintended side-effect of breaking drag & drop to the folder tree, so in the new beta 12.15.2 we had to make a small change to the change :wink: Hopefully it didn't affect the MTP operation but if you're able to, please give 12.15.2 a try and let us know if you see any problems return.

12.15.2 still rockin... :slight_smile:

1 Like

Yesterday i updated my S7 to the june security patch and i tried to use the MTP but sadly opening the folders on the phone brings up explorer. Tried MTP_enable true/false, restarted PC and phone, USB debugging On/Off, even downloaded the samsung usb driver from samsung developers website. Nothing worked. Tried different usb ports on PC. Right now i cant think of anything else to try. Any tips?

They open in Explorer even when you click on them in Opus?

Is the phone set to MTP file transfer mode? Android has several modes it can be in when plugged in via USB.

(Using FTP instead of MTP is always my general advice, as FTP is more reliable and wireless. The Olive Tree's FTP Server is a good option for Android.)

1 Like

Yes, in DOpus i see the phone in This PC. I click on it, then i see Opus open it like a virtual folder, with the Phone memory and SD card. If i double click it opens explorer.

Yep, its set to MTP. And yes, i know you advise everyone to use ftp :slight_smile: read all topics on the forum. But its a lot slower. I use Mixplorer filemanager, for me its basically the android opus. It has a nice ftp server feature. And i use it when im in the livingroom, avay from the PC.

I cant belive the security update did this. I was so happy the other day. If i get home i will try everything again, not giving up. Thanks for the suggestion though!

Came to my mind:
"Treat all virtual folders as real" setting didnt count either. Well, tried everything again. Opens in explorer no matter what i do.

I found something. Sorry for hogging this thread. So if i pin the phone to quick access in the foldertree and try from there, opus opens it in the lister, either the phone or the SD card. Same if i set the foldertree to include virtual folders, then phone can be accessed from there in the lister, internal and SD both. Now i need to sleep on this, i will test file operations tomorrow.

Where are you opening it from when it opens in Explorer?

If i create a new tab (in my settings it defaults to This PC) i see my drives and the phone. Double click on phone, the lister then displays the 2 storages (internal and SD) like a virtual folder. If i double click on any of them, they open in explorer.


But if i open the folder tree (in settings i checked to display virtual folders in tree), under This PC i see the drives and the phone, i open the phone tree by clicking the little + icon, there are the 2 phone storages, and if i single on any (internal or SD) the lister then displays them normally and i can work with them. No explorer involved.

Thanks for that, this should be fixed now in 12.15.3.

1 Like

Thank you! Life is awesome again! :slight_smile:
Tested, works like intended!

1 Like

This seems to be broken with my Pixel XL. Directory Opus 12.17, Android 10.

When I transfer files with explorer it works. When I transfer with Opus it hangs after about 100k of data is transferred. I tried both mtp_enable on and off.

Nothing changed on our side.

With Android, using FTP is a lot easier and more reliable than trying to get MTP to function properly.

FTP is extremely slow though, that's the problem.

Well, I may have found a solution. You can use ADB to direct TCP ports over the USB connection, so it charges and works at much higher speed than wifi.

It's still slow because FTP is slow e.g. with many files, but it's slightly better.

Edit: I should mention that I only recently upgraded to Opus 12. Why doesn't it work when Explorer does?