MTP in Folder Tree view

I really, really like the new MTP support in DO 10.5.0,0. Something that's been wicked lacking in available phone apps and PC file managers.

One glitch, however. When in Tree view, clicking on a folder within the tree does not open that folder or display the sub folder tree. Instead, you must double-click on the folder you want to open in the file panel, not the tree panel. That folder then opens. To drill down further, you must double-click on each subfolder in the file panel as you work your way down.

Not a big problem, but one that would be nice to correct. This glitch may be limited to my systems. The Desktop i"m using is still running XP SP3, and the MTP device is a Samsung Galaxy S3 running Android Jelly Bean.

Otherwise, I can open files on my MTP device normally, just as I can any other file displayed in any other drive in DO. Folders of images open automatically in thumbnail view. A very well worked out feature.

On the Galaxy S3 I'm using the ES File Explorer app, which allows me to fully access my desktop system via my wireless network. Doesn't allow me to access the cell phone from my PC, though. Just access the PC from my cell phone. I was kinda hoping that the new MTP support would allow DO to recognize my device on the wireless network so that I could go untethered, but I guess that would take a lot more doing.


Clicking on the tree works okay for MTP folders here, FWIW.

Maybe the device is busy the first time you click. MTP only allows one file to be read at a time, so any columns which display file info (as well as things like thumbnails) can tie up the device while they get that data, and different devices seem to handle it slightly differently.

Thanks for your reply Leo.

I didn't know that. Perhaps I was trying to flip around through the folders too fast in my excitement, although that doesn't explain why I could double-click on a folder in the file panel and it would open, but not in the tree panel.

I'll try exploring my MTP device folders more leisurely tomorrow and see if that gives me better results.


Well, MTP is not working today.

In Tree view, clicking on any folder in the MTP device Tree panel merely refills the File panel with the same root folder and file list. It does not display the folders and files in the folder I clicked on. The only way to access any subfolder folder is to double-click on that folder in the File panel, not in the Tree panel.

Worse, today I cannot read the "External SD Card", as the Galaxy S3 refers to the optional SD card in the phone. Yesterday DO could read that card fine, albeit with the same inability to use the tree panel to access the folders. Today it displays a list of all of the subfolders in the File panel, but in the File panel it lists all but one of them as being empty. Double-clicking on any one of the empty folders does nothing. Double-clicking on the one folder in the File panel list that DO sees as not empty opens that folder and displays its files properly. I can then and can open the files normally.

Using the ES File Explorer app on my cell phone, I can see all of the files in the folders that DO reads as empty. I can access and open all of the files normally via ES File Explorer, so I know that the folders are not empty.

Double clicking on a folder in the File panel that DO reads as not empty opens that folder in the File panel and expands the folder Tree appropriately. However, again DO lists those subfolders as empty. Double-clicking on one of them collapses the tree back up one level.

What does Windows Explorer show for the phone?

Thanks Leo.

Sorry for the delay in replying. I was out and didn't have access to my desktop.

It's been so many years since I've used MS's Explorer that I forgot it existed.

First I plugged the MTP device into a USB port on my desktop machine and opened DO. As previously, the External SD Card tree showed a list of subfolders in the File panel, all showing as "empty". I closed DO.

Using Explorer, the folder tree opened right up for the MTP device, displaying the folder tree and the file panel with the contents. Clicking on a folder in the tree for my External SD Card opened that folder normally, displaying its contents in the File panel. Clicking on a subfolder under that folder in the Tree panel opened it normally. Double-clicking on a file in that subfolder in the File panel opened it normally.

I then closed Explorer and reopened DO. Again the Tree panel showed the folders. Again, all of the folders in the File panel showed "empty", except for the folder that I had opened in Explorer. I clicked on that folder in the Tree panel, and the tree expanded normally. Clicking on the only subfolder under the expanded tree that wasn't displaying as "empty", again the only subfolder I had opened in Explorer, further expanded the tree and displayed the contents of that subfolder in the File panel. Double-clicking on a file in the subfolder opened it normally.

Do I need to tweak something in my DO settings?


What does your Opus config look like?

I would try turning off any columns that cause file contents to be read (image dimensions, Description column, etc.)

It may also be worth turning off Preferences / Folder Tree / Contents: Zip files and other archives in case an archive on the MTP device is being scanned by the tree. (I'm not sure if the setting affects MTP devices, but it's worth a quick test.)

After making the changes, fully exit Opus and then restart it to see if they help. It seems like something is tying up the device, so that will eliminate some of the possibilities at least.

Howdy Leo,

I've spent the last several hours trying various Preferences changes in Opus, closing Opus normally, followed by ending the Opus process in Task Manager before reopening Opus. No change, except for my first test after unchecking all boxes in the "Show in folder tree" options. The MTP device did not show up at all. Reticking the option that allowed the device to redisplay in the tree, the same problem reappeared, so I reticked the other settings as they were not the cause.

Throughout my testings, the folder tree and files continued to display and open as they should in Windows Explorer. I've checked the settings for Explorer, but don't see anything that I have or don't have ticked that seems contrary to Opus's Preferences. That my MTP device can display and be accessed normally in Explorer gives me hope that I can get Opus to work normally with the device as well, but no luck so far.

I tried opening Opus without the folder tree, but that didn't allow Opus to read the falsely "empty" folders, either. I never have had "Zip files and other archives" ticked in Preferences, so that's not the problem. The columns in the MTP File panel are very limited: Name, Size, Type, Modified. Additional columns display when accessing folders with music files, but I have wicked few music files on my cell phone, unlike my daughter who has terabytes of music files on hers.

I've looked at my Preferences settings for "Explorer Replacement" and "Windows Integration", but not seen anything that looks conflicting there. I must be missing something somewhere.