GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Netweork drive doesn't 'stick'

This problem in Win 10 Pro arose after the installation of Win 2004 update.

The LAN 'S' drive is a Linux-based headless server, and has been in use for several years without any issue. It continues to work with other computers that have not gone to Win 2004 level, and remain as Win 10 Pro 1909

After upgrading to Win 2004, opening DO seems delayed compared with previous history, because, while it opens quickly with on-board drives, it then takes 1 - 3 seconds to reload and run out the full folder tree showing the network drives.

After a reboot, and once the DO folder tree has been rolled out showing network drives, it shows the 'S' drive to be connected, but will not access it. In trying to re-map that drive, there is an error message that the drive cannot be found. The server is identified by the name 'Saturn', and it shows in the network browsing dialogue box, but is not accessible. I have pursued all the normal, usual, and recommended methods to get it connected, but nothing worked.

When I entered the path \Saturn\Server explicitly, and mapped it to 'S', it would not connect because that drive letter was already mapped. I had expected to be asked if I wanted to disconnect the pre-existing mapping, and I accepted that, but it would not connect.

Manually disconnecting the 'S' drive as mapped, and re-mapping it using \Saturn\Server explicitly, worked instantly.

After every reboot, the 'S' drive continues to show with a green tick, but cannot be accessed. Remapping the drive letter 'S' explicitly, after having first disconnected its previous mapping, works every time.

Since this is the office server, clearly access to the 'S' drive is vital, and this workaround is not arduous, but it should not be necessary.

Can you please shed some light on this issue?

Regards,
Max Williams

[I have since had occasion to update an older computer which has progressed to Win 2004. It uses DO9

Same effect - and this did not occur after the 1909 update, but only after the 2004 update. That machine now accesses the 'S' drive by VPN. Because of COVID-19 lockdown, I cannot be sure why that employee has been able to see 'S' in File Explorer, but not in DO, or whether that issue has been resolved by techniques I have found effective and suggested to her.]

Windows 10 2004 is a complete disaster in terms of network drives, unless you're using a Microsoft Account. The issues also affect Explorer and everything else, and boil down to the OS corrupting its credential store. This also causes OneDrive to randomly lose its login details and Chrome to randomly lose all account information.

Microsoft knew about these issues from testers back in April but released the update in July anyway. They still haven't fixed it.

The only solution is to roll back to 1909, which is what I did. (Or switch to a Microsoft Account, if that is tolerable.)

(Opus is not involved at all in the way network drives are mapped or connected to. That is all down to Windows.)

1 Like