GP SoftwareTwitter
Opus FAQsManualCommandsObjects

New Docs/ActiveX plugin


#60

Great work nudel! I'll start stress testing this baby tomorrow :stuck_out_tongue:

/Anakha


#61

Hi,
I have been so happy that finally a 64 bit version arrived - however it doesn´t show up/work at all within my opus - could it be because I use the german version ?

best regards
Lothar



#62

See if there's another docs.dll within the deutsch folder on the right of your screenshot. If there is, exit Opus, delete the DLL, then start Opus again.

The problem will be taken care of when the plugin becomes part of the proper Opus installer and myself & GPSoftware have been discussing a way to avoid the problem with future plugin updates.


#63

works fine now - thanks a lot.

Best regards
Lothar

P.S - basically, though it hasn´t been demanded (I closed everything as recomended to avoid restart) it has been only a restart that was missing, I did after my rendering had been finished :blush:
The only dll within the "Deutsch" folder was a movie.dll I deleted to avoid conflics withe the movie.dll outside.


#64

Leo,
When I tried to install the plugin on my Vista 64 box I got the message:
"Directory opus is not properly installed on your machine.%n%nYou must install or reinstal Opus before atempting to install this plugin"

Reindtalling OPus did not help. Any ideas?

Best regards, Toller


#65

That message means that the installer could not look-up the Opus directory in the registry.

You can either manually add the registry setting or install the plug-in by hand. Fixing the registry is a bit more effort but might save time in the future. I'll describe both things and leave it up to you to decide which to do depending on your familiarity with registry editing:

[ul][li]Registry setting:

Open RegEdit.exe and navigate to here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

If there isn't already, create a DOpus.exe sub-key.

Within that key should be two REG_SZ values. The default (nameless) value should be:

C:\Program Files\GPSoftware\Directory Opus\DOpus.exe

There should also be a Path value set to:

C:\Program Files\GPSoftware\Directory Opus

(Of course, modify those if you've installed Opus somewhere else.)

[/li]
[li]Alternatively, install the plugin by hand:

Grab the zip of the plugin, instead of the .exe installer, extract it somewhere.

Exit Opus. (See here.)

Using Explorer (or something other than Opus), copy the files you extracted into your Viewers directory. The directory will usually be here:

C:\Program Files\GPSoftware\Directory Opus\Viewers

Restart Opus.
[/li][/ul]


#66

Leo,

Thank you for your prompt reply. Changing the registry did not help. I reeceived exactly the same message. Do you check only this value in the registry in your plugin?
Manual install from zip file works fine.
Best regards, Toller


#67

The plugin itself doesn't use the registry at all (except to import the old version's configuration, but if that fails it will ignore it and carry on).

The only thing that depends on the registry and which could put up the message you're seeing is the installer itself. I had a look at the installer to refresh my memory and it will show that message if:

a) It can't read the Path value under ...\App Paths\DOpus.exe.

or

b) It can't get the version information from dopus.exe within the path the registry points to. (You can check that by opening Properties on the exe and making sure some version numbers show up. Would be weird if they didn't, though.)

or

c) The registry points to an invalid path (but that should trigger (b) first).

I can't think of or see any other things that could result in the error message. Maybe if the installer is run in some kind of compatibility mode it might go wrong, but it shouldn't do that by default. (The x64 version of the installer is a 32-bit executable, but it's written in a way that it can install 64-bit programs and registry settings, and I've tested it on my own x64 machine. That said, I've only tested it using an Administrator account. UAC was enabled, of course, but sometimes there are slight differences between Admin confirmations and "over the shoulder" elevations, so if you're not using an Admin account let me know and I'll test that.)

Running Process Monitor may reveal which operation the installer is attempting that fails, if you feel like investigating. If not don't worry too much as you can always install the plugins by hand, and they will also be included in the next Opus update.


#68

Leo,
I quickly looked and it seems that all three reasons to fire the message are not satisfied. Something strange happens. I also use an Administrator account with UAC. You are right, for installing a plugin it does not matter.
More importantly, I found two glitches. It is not very reproducible but it happens quite often. The viewer shows correctly contents of some MS Word 2007 file. When I switch quickly to other Word file, the Viewer shows the binary content. After switching back and force, the Viewer finally starts to show correct content of the second file. Then something weirder happens: the Word file shows some characters in red color as those in revised version. It seems for me that some memory leakage happens. If I open this file in MS Word it also shows the revised version while if I copy this file to other computer, it looks normal. After restarting everything is also OK. This file is a little bit specific because it has a lot of equations.
Best regards,
Toller.
[/img]


#69

hmm,

is this new, that contents of zips are shown in the preview? that´s very nice! Is this also possible with other types of archives like rar?


#70

See the last few posts on the previous page of this very thread. :slight_smile:


#71

I've seen that on x64 as well, but I thought it was only happening because my x64 virtual machine is so slow that something times out while loading Word or the Preview Handler which doesn't happen the second time a file is loaded. I'll look into it more if it's happening for real. Unfortunately it isn't easy for me to send a test version for you to try until the next Opus release as the plugin code depends on some new (unreleased) Opus features now (for translation of the plugin into other languages).

I think what you're really seeing is that sometimes the file is opened by the Preview Handler (which has less functionality and won't underline characters in red, etc.), but sometimes the Preview Handler fails to load (due to the stuff discussed above) and the plugin falls back on using Word itself (which does do the underlining in red, etc.).

You can tell that this is happening by the different program name in brackets next to the file name, just above the viewer itself. If I fix the above problem it should fix this problem as well.

There's no memory leak that I can see. (A memory leak is when a program keeps running and doesn't free some memory even though it is no longer needed.)


#72

Leo,
I tried to play a little bit more with switching between two Word files. Both files are only 12 kB in size. It takes very long time to load the second file. Furthermore,after sufficient long playing with switching, the WINWORD.EXE process stays in memory when a Lister is closed. It seems that an object is not deystroyed. Isn't a memory leak?
Best regards, Toller


#73

If WinWord.exe stays in memory for longer than 10 minutes then it might indicate a problem. Otherwise it's normal. COM often keeps things running for 10 minutes in case they are used again.


#74

Leo,
Winword.exe remains in memory certainly more than 10 minutes. BTW in the Explorer I can switch between two word files very quickly with a Preview Pane active.
Success in fixing this problem in new version of the Previwer. Keep your good work.
Best regards, Toller.


#75

Leo, i have an error when i try to search string (ctrl+f) in a html file...
but only when i open file by double clic (show command to html file in file type)...


#76

I see the Ctrl-F error message with IE as well. I'll look into it when I get a moment.


#77

My biggest problems with the ActiveX viewer plugin and why I've always had to disable it in the past:

  • It tries to open the file too soon after I click on it and interferes with me opening up the file. This is particularly true with word. I double click the Word file (2007 but saw this in 2003 as well) and invariably I get an error message somewhere.

  • If you do any Flash SWF development and have the debug Flash player installed, it will popup error windows when you click a SWF that shouldn't be run locally (meaning you get Security Sandbox Violation error messages). It would be great if there was a 'file size' cutoff, in the absence of an actual solution, as being able to see small SWF's is helpful, but the big ones invariably have security violations.

  • Viewer pane hangs and can't be closed: I haven't used the new version much yet so will let you know if this is all fixed. Just listing this as one of my old reasons to disable ActiveX viewer plugin.


#78

Leo, notice that copy (ctrl+c or context menu) don't work too...


#79

I usually close viewer pane before double-clicking files. I just tried it with the viewer open and an Excel file and I do get the a slightly odd result of two Excel windows opening, but apart from that blank window (which can be closed) it worked okay. I'm using 2007 with the Preview Handlers so I suspect stranger things would happen with earlier versions of Office where the full program is run as the viewer.

I don't think there's anything the plugin itself can do to fix this. Perhaps Opus could have an option where it waits for a double-click to happen after the first click, and only opens files in the viewer if the second click does not happen in time. i.e. Double-clicked files would not be displayed in the viewer and there would be a delay before single-clicked files were displayed. I think that delay would be somewhat annoying, though, so unless it could be configured only for certain file types I'd rather live with closing the viewer when it wasn't wanted. Just my take on it, though.

Of course the real problem is that Office is full of bugs but there is no realistic chance of getting them fixed so we have to work with what we've got. :slight_smile:

Why is there a correlation between file size and security errors? Just because bigger files tend to do more stuff or something else?

Is it possible to have both the debug and non-debug Flash players installed? If so then it may be possible for me to make the plugin look for the non-debug one.

I don't really understand though, since by default the new ActiveX plugin displays Flash files via Internet Explorer, so if you have annoying error messages as a result of using the debug Flash player, doesn't the same thing happen when you are browsing the web normally?

The new plugin has fixed several compatibility problems but without more information I can't say whether it will have fixed the problems you were seeing. ActiveX means running someone else's program within, or tightly coupled to, Opus and so if that other program is buggy then it can crash or lock-up Opus and there's often not much we can do about it (except try to avoid whatever situation triggers the bug).

The new ActiveX plugin runs all ActiveX controls in a separate process which should isolate Opus from some crashes, but it is still possible that a an ActiveX control could go unresponsive or do silly things and hang the window that it is in.

If you find any lockups then let me know the kind of file you were viewing, and which ActiveX control was viewing it, and I will investigate them.