New Text Document missing from context menu

For some reason, Directory Opus does not display "Text Document" under the "New"option from the context menu when you right-click.

I thought this was a Windows issue, but I've verified the correct registry settings, the item appears under Windows Explorer, and it is also listed in TweakUI. Only Directory Opus is not aware of it.

Is there something that might be interfering and preventing DO from listing the option?

Do you see other New entries?

What if you hold shift while you right click and then open the sub-menu?

I see all other entries. DO and TweakUI was listing an option for VLC WAV file that Windows Explorer did not list. That was the only other inconsistency. I deleted VLC WAV because I never use it, and to see ensure it wasn't causing a conflict.

The list of items doesn't change.

Sorry, I didn't say, but I'm running Windows XP SP3 and version of DO.

Does upgrading to the latest version of Opus make any difference ?

No luck there either.

I've suffered this bug for many months, maybe 6 or more. I had added some new types the the new list include HTML and PHP. I don't know if that's when the problem occurred, but when I did see it was missing I assumed I may have accidentally removed in the process of my edits. Only now have I bothered to look into the problem.

Please run my FileTypeDiag tool, specify .txt as the extension and post back the result (as a private message if you prefer, though the info shouldn't contain anything sensitive).

PM has been sent. Thanks for your assistance with this. Let me know if there is anything else I can provide.

Try importing the attached .reg file: (287 Bytes)

Alternatively, if you'd prefer to make the edit by hand, open RegEdit, go to HKEY_CLASSES_ROOT\textfile and set the b[/b] string to Text Document

I think the problem was because that type name was missing. (Explorer will use the FriendlyTypeName value from the same place, which you have, but it doesn't look like Opus uses that. Normally both the (Default) and FriendlyTypeName are there but something seems to have removed the (Default) one on your machine.)

Still no joy.

I've imported the reg file, and I can conifirm that the key was created. I exited DO and opened it again and the option was still missing. So I rebooted, just to make sure but it still hasn't appeared.

Could you post screenshots of the File->New menu in both Opus and Explorer?

Sure thing, Jon. Images attached.

If you run the Opus command Filetype NEW=.txt does it work?
(add it to a button or run it directly by pressing > to bring up the command field)

I didn't know about that command feature... neat.

Unfortunately, it didn't work.

To ensure I didn't mess up the syntax I tried with .php and that worked.

Are you sure you've not turned the new .txt filetype off from within TweakUI...?

Yes, I'm sure of that. I checked the option and if it was off, it wouldn't display in Explorer.

Is there anything else I can do to help troubleshoot this? I know it's hardly going to be a priority for the developers since I'm perhaps the only one having this issue, and it's not exactly a critical fault.

I may try creating a duplicate option, in hopes the duplicate appears whilst the original does not.

Hey Dr. I had the exact same issue with .txt missing from my context menu. So I went into my reg, backed up the context key for the existing .txt entry, then deleted the txt shellnew entry and recreated it, and it worked from that day forward. Note that though I am on Win 7, this should still fix your issue.
This is also how i remove items i simply so not want on my context menu, and how to add items I 'do' want.

Step 1: To Remove an Item from "New" menu:

  1. Open regedit and expand "HKEY_CLASSES_ROOT" key.

  2. Now look for the file type which you want to remove from "New" menu, e.g. for removing TXT file type look for .txt key

  3. Expand it and delete the "ShellNew" key.

  4. Thats it. The file type will be removed from "New" menu.

Step 2: To Add an Item in "New" menu:

  1. Open regedit and expand "HKEY_CLASSES_ROOT" key.

  2. Now look for the file type which you want to add in "New" menu, e.g. for adding TXT file type look for .txt key.

  3. Right-click on it and select "New -> Key" and name it "ShellNew" (minus the quotes).

  4. In right-side pane, right-click and select "New -> String Value". Give it name "NullFile" (minus the quotes) and press Enter.

  5. Thats it. You'll immediately get the file type entry in "New" menu.

I'll include my .txt shellnew registry entry for you JUST in case. Just unarchive it, open it with your text editor to confirm that its harmless (ALWAYS a good idea!) and then double click it to add it your registry.
Would work best if you already deleted the OLD shellnew entry FIRST!
txt_shell_new.rar (227 Bytes)

Gaaah!!! I HATE not being able to edit my posts!! Why can i not?!

ANYWAYS... please back up the full .txt key by righ clicking on it and selecting 'export' BEFORE editing it.
Always best to be safe, even for a simple operation like this.

And don't be put off by my 'hand-holding' approach. I do not know your tech level, and am used to step by step walk-throughs for my clients.

Here's why.

Thanks for the suggestion, MacDaddy. Unfortunately, it didn't work. It did remove it, and return for Explorer, but it still doesn't appear for DO.