No Metadata for FLAC-files

The Metadata Panel doesn't show the Metadata of FLAC-files anymore.

Working fine here. Make sure your files are actually FLAC (not something else with the wrong extension) and have proper FLAC tags (Vorbis Comments, not ID3 tags which should never be on FLAC files).

Hmm, I didn't have any problems with v12. With v13 I can't even write something new. The only thing that sticks after saving is "comment"

Have you tried other FLAC files? Have you checked that the files really are FLAC etc.? Can you provide an example file that has the problem?

It's the same with all my FLAC-files. All columns with music-metadata are empty. DOpus 12, Aimp and Mp3Tag can read/show the information. It's also shown in Properties/details of the file. I appendet the smallest file I could find. (670.5 KB)

I'd say that ain't so bad :slight_smile:

Flac columns and metadata panel work here too.

That file works OK for me, in both Opus 12 and 13.

Only thing I can think of that might cause a problem is if something is blocking Opus from opening the file, but that would be unusual for an audio file.

@Hardkorn: Audio Tags is checked in preferences
What I tried now is to delete all tags with Mp3Tag and then write something new with DOpus. All information disappears when saving it but Mp3Tag can read what I've written. So writing Metadata works but reading not.

So both the file display columns and the metadata panel show none of the tags?

Those two things use different code for extracting the metadata, so if both are failing it's quite odd, especially if you can write to the file.

It seems to be something in my configuration. I temporarily renamed my config-folder to have a virgin DOpus and everything works fine. How can I find out what causes the issue?

I can’t think of any config settings that would change what the metadata panel shows, unless a plugin or script is locking the files when the directory is displayed.

It's definitely something in the folder ConfigFiles. I renamed this folder and it worked again. Which file inside this folder could probably cause that issue?

The issue was caused by the file "viewerplugins.oxc". After deleting the file DOpus created a new one with less lines so some old stuff inside

made the trouble. I append the old file here so you can have a look on it. (446 Bytes)

Compare it to your current version of the file and it might tell you which plugin was causing the problem.

Can see several ones in the list which aren't part of the default install, including a few I don't recognise at all.

I currently see 15 plugins in the new file corresponding to what I see in preferences. There are 11 lines more in the old file. I've no idea where they came from possibly years ago. I'm just glad I could solve the problem. Thanks for your support.

Lines for plugins that don't exist shouldn't affect anything, FWIW.

I have the same FLAC problem with Directory Opus 13. 12 works, but not 13.
How can I fix it?

Deleting /dopusdata/ConfigFiles/viewerplugins.oxc apparently solved it above. (Paste that into the path field and it'll find the correct file. Best to delete it via Explorer or something other than Opus, after using File > Exit Directory Opus to shut it down completely.)

But please backup the old one first if you try that, and if it works please send the old and new files to us so we can see what changed and try to work out what was wrong.

1 Like