No thumbnails with specific archives extracted via 7Zip

Hi. I feel like this only started happening recently to me. I'll download some galleries in zip files, unzip them into separate folders, go into a folder, and I'll see that dopus doesn't load the previews for the images in the thumbnails like you expect it to. Instead, it just shows the icon of the default program used for opening images (irfanview's, in my case). Here's some behavior I've noticed:

  • Refreshing the view does not make the thumbnails load.
  • Doesn't matter the file format. png, webp, jpeg, all behaves the same.
  • If I move the pictures to a different directory, it does work in making it generate the thumbnails.
  • If I navigate to these pictures that haven't loaded on dopus on windows explorer instead, it loads them just fine.
  • Since it doesn't load image thumbnails, it also doesn't load them in folder thumbnails. So it looks like the folders are empty, even though they're not.
  • Restarting my pc doesn't seem to fix it either.
  • Converting images with dopus' converter, the new images load their previews just fine.

I've tried tinkering with the settings but nothing has fixed this behavior. I'm on the most recent version of dopus. Any idea what could be going on?

Here's what it looks like when I take an image, move it somewhere else, then back into the folder. It now loads fine, but every other thumbnail stays unloaded.

Does turning off the thumbnail cache (Preferences / File Display Modes / Thumbnails) make a difference to what happens?

Do you have antivirus/anti-ransomware software running that might be blocking Opus from opening the files in some situations? Or something that might be indexing the files when they're first created, and blocking things from opening them at the same time?

When you move the files out and back into the folder, are you doing that with Opus or something else? Is it to another folder on the same drive, or a different drive?

  1. No difference.

  2. Nope, just windows defender. I use Voidtools' Everything. That indexes files. Could that be it?
    Update: Closing Everything doesn't seem to fix this.

  3. With dopus. Literally ctrl+x, back out of the folder, ctrl+v, and now it loads the thumbnail. Then cut again, go back into the folder, paste.

One more thing I tried just now: if I rename an image, nothing seems to happen at first. But if I back out of the folder and go back in, now it loads the thumbnail.

How long is the folder path?

What kind of drive is it?

Is could storage involved?

Seems to happen anywhere. In my C drive downloads folder (on a nvme drive), on my root G drive (external HDD).

I forgot to mention, but I'm using 7zip to extract these zip files.

If I use the "extract all" context command (if that a windows or dopus thing?) it loads the thumbnails fine.

If I make use of dopus' feature of going inside zip folders without extracting them, I do see the thumbnails there. But then I extract with 7zip and no thumbnails.

No issues here using 7-Zip, but if you're in Opus why not use Opus to extract the files?

Well, I'm used to using it for zipping and unzipping. And I like that I can extract to the current directory or a folder. I'd like to keep using it.

If you have anything else you'd like me to try, please let me know.

Opus can do the same.

A process monitor log might reveal something.

DMed you the procmon logs, and also a zip file that exhibits this behavior. I notice it only seems to happen to zipped galleries I get from select websites, for whatever reason.

The issue is an error in 7-Zip, as well as whatever created the Zip file.

7-Zip is extracting the files and setting the Offline attribute on them, which it shouldn't do. (It must also have been set on the files within the archive by whatever created it, which is also probably a bug; it's not an attribute that makes sense to preserve when archiving or extracting files.)

The Offline attribute indicates a file is not really there (e.g. because it's in cloud storage and not stored locally). Opus won't try to thumbnail a file with it set (except via a cloud storage API's thumbnailer) as that would normally cause the file to be pulled to the local system.

That attribute should never be set on a file that was just extracted from an archive to a local disk.

We had a similar issue in the Opus archives plugin, which is also based on 7z.dll. I don't think it affected Zip (which the plugin doesn't handle), but it affected some other formats. We corrected that a while ago when someone reported it. Opus will now avoid setting the Offline attribute (or any others which don't make sense) when extracting things via 7z.dll. But we can't do anything about other tools, including 7-Zip.exe, incorrectly setting the attribute on files that shouldn't have it.

1 Like

Okay, I've switched to using Opus to extract files. Works great, thanks. :>

Is there anything I can do about files that I already extracted the old way that are still toggled to offline? I didn't find the property on the metadata pane. Moving them to another folder and back works, but it's a bit slow and cumbersome to do folder by folder.

The DOS attrib command can clear the O attribute:

If you have a lot of directories to do, you could set up a button to run that command and it should fix them.

Apologies, but I'm having a hard time figuring out how to construct the exact script I need for a button to do this. I tried the SetAttr PIN and DEHYDRATE thing that Jon mentioned, but I must be doing this wrong because nothing's happening. If it's not too much trouble, could you help me figure out what the command editor should look like to do this? :x

Edit: Okay, if I have "SetAttr PIN=on" in the command editor and run it from there, it works. However, outside of the command editor the button is inactive. How can I make it run on the currently selected files?

Edit: Never mind, I ended up just running the cmd script at the base of all the folders and fixed it.

I use this button:

<?xml version="1.0"?>
<button backcol="none" display="both" label_pos="right" textcol="none">
	<label>Clear Attrib for Find</label>
	<function type="batch">
		<instruction>attrib -x -p -u -o {sourcepath}* /s /d</instruction>
		<instruction />
		<instruction />
		<instruction />
		<instruction />
		<instruction />
		<instruction />
		<instruction>// -O  Offline</instruction>
		<instruction>// -P  Pinned Attribute (Windows 10) This refers to the &quot;Always available on this device&quot; setting for OneDrive files.</instruction>
		<instruction>// -U  Unpinned Attribute (Windows 10)</instruction>
		<instruction>// -X  No scrub file attribute (Windows 8+)</instruction>
		<instruction>      </instruction>
		<instruction>// /S  Search the pathname including all subfolders.</instruction>
		<instruction>// /D  Process folders as well</instruction>

1 Like