No video thumbnails when file has ALP attribute set by QSYNC, OneDrive or similar sync app

I cannot get Directory Opus generate thumbnails for video files like mp4.


  • Windows File Explorer generates thumbnails and after that they are also visible in Directory Opus.
  • If I make a copy of video file or folder, then Directory Opus generates thumbnails.
  • Directory Opus also generates thumbnails on network drives and on OneDrive folders

Does not work:

  • I open folder that does not yet have thumbnails pre-generated and Directory Opus will not generate "missing" thumbnails.

I have tried all tricks and tips I have found from this forum. I cleared thumbnail cache in both Windows and DO, turned on and off the movie plugin and its generate thumbnail options. Also have tried DO 12.23 and 12.23 beta 2.

I found out that files that don't get thumbnails generated have "ALP" attributes in file properties / details. Files that get thumbnails have only "A" attribute. Not sure what sets that kind of attributes.

Found a solution already. The ALP attribute is set by QSYC app that syncs my files to QNAP NAS. Lately QNAP introduced a feature "Space-Saving Mode" that keeps the files on NAS but shows them as some kind of links on local disk to save local disk space. QSYNC seems to mark all files with "ALP" even those files remained locally on my hard disk. Maybe a bug in QSYNC.

This is similar that OneDrive and other network sync apps have, that you can have file visible locally, but in reality it is only on cloud and will be downloaded locally only if you open the file.

So my solution was to disable that "Space-Saving Mode" and then the "L" attribute was removed from all files, and then Directory Opus generated all thumbnails fine. So seems that if the file has the "L" attribute set, then Directory Opus doesn't generate thumbnails.

I think this is still a bug in Directory Opus, because Windows File Explorer did generate thumbnails for all those files with ALP attribute, but Directory Opus did not, and Directory Opus in my sense should work same way as File Explorer when it comes to thumbnails at least.

This seems to be an issue with OneDrive as well and discussed in this thread: Windows 10 - Not able to view or preview pictures in Windows Explorer - Microsoft Community

I hope this helps with others here with same problem...

Opus will intentionally avoid bringing down local copies of offline files to thumbnail them, since doing that would make every file in the folder local, defeating the purpose of making them offline.

OneDrive supports thumbnailing files via the server (the server generates a thumbnail and sends that back, without the file ever being sent over the network). (I'm not sure if QSYNC has the same facility or if we would use it if it did. It depends how it's implemented.)

Are the files attributes the same before and after when you thumbnail them via Explorer? Or is Explorer causing all the files to become local copies?

Summary again:

  • All of my files were local even they had the "ALP" attributes
  • Directory Opus generates thumbnails for "A" and "P" attribute files OK, seems "L" attribute affects that DO doesn't generate thumbnails, even if the file is local
  • Note: Directory Opus generated thumbnails for all image files like JPG in same folder, the issue was only with video files like mp4, wmv, why images work and videos not?
  • File Explorer generated thumbnails for all files and after that thumbnails also show in Directory Opus

Today I noticed that one file had "N" attribute and Directory Opus did not generate thumbnail for that either. It seems Directory Opus doesn't generate thumbnails for files with either "L" or "N" attribute. File Explorer does.

I tested your question case:

  • I turned the QSYNC feature back on and now files have ALP attribute
  • Now Directory Opus doesn't generate thumbnails (because of "L" attribute?)
  • I go to same folder with File Explorer and turn on thumbnail view, now thumbnails are generated
  • I refresh same folder in Directory Opus and now thumbnails are visible (generated by File Explorer)
  • I check the attributes of those files and they are still same "ALP"

So File Explorer generates thumbnails for files that have "L" or "N" attributes, and those attributes remain active after thumbnail generation also. I think Directory Opus should do the same.

The N (or I, Windows is inconsistent about which letter it uses) attribute means the file shouldn't be indexed. Shouldn't make a difference here.

The L attribute means the file is a reparse point, which means accessing it can run arbitrary driver code, presumably installed by QSYNC, but who knows what it actually does, unless it's documented somewhere.

If Opus generates thumbs for JPG files but not MP4 then it's pretty weird if it comes down to this. Opus itself generates JPG thumbnails, but doesn't generate video thumbnails (that's handed off to the video components installed on your system).

You could make a Process Monitor log of what happens, which might reveal a detail of what's failing, and which components are involved.

I refresh a folder many times and the file with "N" attribute did not get a thumbnail either. So there must be some issue with "N" attribute files as well.

I sent you the PML log file in a private message...

I tested this with OneDrive. I copy one of my video files into OneDrive folder and moved that into an offline file with the "Free up space" function. After that the file has "ALOUM" attributes. I briefly saw that the thumbnail was removed for maybe half second but was then updated back. So thumbnails in OneDrive folders, even with "L" attribute work.

Also JPG and PNG image files on my local HD with "ALP" attributes work. So does PPTX and many other formats as well. Seems WMV video files also work. So it looks like only MP4 video files with "ALP" attributes on my local HD with "ALP" attributes has this issue.

An new test:

  • I make a copy of existing video, that will get a thumbnail, that has only "A" attribute right after copy
  • After some time, I think QSYNC, will mark the file with "L" attribute and then the thumbnail disappears
  • I open same folder in Explorer which generates thumbnails in "Large Icons" mode, but these don't get visible into Opus
  • I change Explorer to Extra Large icons mode, these thumbnails will come visible to Opus

I had a look at the log file you sent and it seems to be at least attempting to make a thumbnail of the first video in the folder. But the log only includes less than half a second of activity, so it's hard to know what's going on before or after that, or if there are any errors later on.

It looks like the Opus Movie plugin is doing the thumbnail generation. You may find things work better if you tell it not to make thumbnails, so that the Windows Shell does those duties instead. You can do that via Preferences / Viewer / Plugins and then either disabling the Movie plugin entirely, or clicking Configure on it and turning off its Generate Thumbnails option.