Not able to rename a folder?

Hi - I have just tried to rename one of my folders and get the Error code 5: Access is denied (5) message after accepting a user access message? Any ideas why I might be seeing this, please?

It means a program that is running on your system currently has the folder locked in a way which blocks it from being renamed. Or the folder, or its parent, have file permissions which block you from renaming even after elevating with UAC.

If you think it is an Opus bug: Can you rename it in any other program?

Thanks for the quick reply and support.
I did think that so closed all things relating to that folder down but still picked up the same error? I was having a quick look to put back my windows explorer back on but was not quite sure how to do that as everything is defaulting to Opus?

You can run Explorer via the Start Menu, or from Opus via Tools > Open in Explorer.

thanks Leo as you suggest I cannot change via explorer either - saying that the folder is open somewhere but I cannot see where I will have to do a cold start of the machine and try again. Thanks again for the support really good to get such a response etc - ps is the support forum a bespoke bit of software or is it available - one of the best I have seen. Ian

The forum runs Discourse.

thanks again..

Hi I am starting to pick up the same error with Opus Pro again where by I cannot directly save anything from say an email into my opus directly but I can to say the download folder. This is when trying to save a document into say my google drive folder I get the error as shown in the attached image.

Any ideas?

Directory Opus Pro 12.22 Build 7593 x64
OS 10.0 (B:19042 P:2 T:1) SP 0.0

The screenshot says you're trying to rename a file, not save it?

What are the exact steps that you're doing?

Have you tried doing them in File Explorer to see if the same issue happens there?

Yeah sorry, get the same message if trying to rename a file or save a document to a folder. File explorer seems fine just something in the opus not being able to save files

So you get the same error in other programs, not just in Opus?

Just in Opus it would seem. I get this dialog when trying to do anything in opus if I say yet I then get the other error code 2020-11-02_17-37-53

What are the exact steps that you're doing?

How are you "saving a file" in Opus?

Have you tried whitelisting Opus in your antivirus and antimalware? Those can cause strange access-denied errors, especially if you're using Windows Defender.

Hi funny thing is everything has been working for years now - windows did recently do the Win 10 update but not sure if that has something to do with it, I do not see any blocks in the defender firewall either. I cannot connect to opus update as saying unable to connect to remote host even though I think I am up to date in terms of opus. Whats the best way to whitelist ??

Defender blocks things without telling you what's happening. It's quite frustrating, and a really bad product these days.

You can whitelist things in Defender via Settings > Updates & Security > Windows Security > Virus & thread protection.

Note that there are multiple Defender features which can, and do, cause problems, and which have separate whitelists and on/off controls:

  • Virus & thread protection settings
    • Controlled folder access (if turned on)
    • Exclusions
  • Ransomware protection

So you may need to look in up to three different places.

The quickest thing to try to see if Defender is the problem is to turn off all of those parts of Defender. If things work properly after doing that, then you know Defender was the problem, and then it's worth time working out how to whitelist things. (Or, better, switching to an antivirus that doesn't suffer from so many false positives or at least informs you when it blocks things so you know what happened and how to fix it.)

If it looks like Defender isn't the issue in the end, please answer my other questions in the previous replies.

Thanks for the detailed reply Leo I will take a look.

I can see this might well be something to do with the controlled folder access and have now given opus access and looks like I can rename folders etc so thank you for the great support in my understanding of what has been going on here. Best Ian

1 Like