"Not Implemented" when double-clicking MSOffice files

I am using the most current version of DOpus. At start, I can click Word or PowerPoint files and they start correctly. However, after I work for awhile, clicking a filename brings a dialog box that says...
(filename) Not implemented. This problem only seems to happen with MS Office files- doc, docx, ppt, pptx... and it was not a problem until recently (I have been using DOpus forever).

I can right-click on the file and open the file with the "Open with" menu option. (and yes, I have clicked the "open with this every time" option frequently).

If I entirely exit DOpus and restart (or shut down and restart), it temporarily fixes the problem... but after an hour or so, it starts to happen again. I have tried using the "file type" dialog box to fix this, but am not successful with it.

This does not ever happen with Windows Explorer. Even if DOpus is unable to open a file, the Windows file manager has no issues.

DOpus is set to replace Explorer. Changing this setting does not resolve the issue.

Help?

Can you post a screenshot showing that dialog box?

2021-04-04_8-36-48 ppt errpr

Whether it is a .pptx, .docx, or .doc file... the box says no more than this. No error codes ever display.

This shows a fuller screen... showing error with an old doc file

So that you know, after I posted the original issue, the problem went away for a couple days and then (as it has been doing for weeks now), the issue reappeared on Sunday morning. That is when I made these screen shots. At that time, I started Windows Explorer which opened my files fine.

This morning, after rebooting, DOpus is working again. (I'm sorry I stretched three over replies... I just didn't think ahead.)

It seems to be a problem that happens with Office in Explorer as well, with lots of other people affected without Opus being involved, from a quick search.

Reinstalling Office seems to fix it for some people, at least.

For me, this never happens with Explorer and only happens with DOpus. When DOpus does have this problem, Explorer does not. Resetting DOpus solves the problem temporarily.

I am almost certain that the answer to the problem is found in where the office EXE files are now kept. (They are not in Program Files x86). DOpus does not have this exe path in the file types list.

1 Like

Anyone who solved this problem?

My "solution" so far has to set DOpus to exit when I close a lister. For me, DO will suddenly seem to lose file associations. Everything is working fine, then suddenly it stops opening Office files (giving me the error message). The problem resolves when I exit DO and restart it. (This is another thing that leads me to believe that this is not an Office problem, but a DO problem.) So, I have set DO to exit when I close a lister. This removes the small icon in the taskbar, but it doesn't slow things much.

Settings>>Preferences>>Startup>>check "shutdown Directory Opus when the last Lister closes"

I also "pinned" DOpus to the taskbar, so that it still readily available. It just doesn't stay in memory.

Did either of you try reinstalling Office? That seemed to fix the problem for other people who were seeing it in File Explorer.