.odt files (OpenOffice) with preview pane

I have a directory of about 10 .odt files. When I have the preview pane on and I click on a file, it looks like the preview pane attempts to display a preview, fails, then decides to open the file. The effect is that if I single left-click any of the files, they open automatically. My workaround is to turn off the preview pane, but just wanted to bring attention to this.

What happens in File Explorer? The Office document viewer(s) are not part of Opus and I’m not sure any support ODT files. I’m surprised the ODT extension has been assigned to any of them.

Just tried it and File Explorer successfully previews the text.

Back at my PC now, I see Microsoft Word's viewer handles .ODT files, so it should be the same in Opus as it is in File Explorer.

In Opus, if you go to Preferences / Viewer / Plugins and configure the ActiveX+Preview+Office+Web plugin, which things is .ODT assigned to?

It'll usually be "Microsoft Word" under the Preview Handlers section at the top, but it may be different if you have other viewers installed on your system.

If "Microsoft Office (legacy)" is on, try turning that off.

It's also possible that anti-ransomware software may be blocking the file from being opened by some software and not others. It's ultimately the Office viewer that reads the file, but Opus will need to open it first before passing it on in some situations.

ODT is assigned to Microsoft Word (32-bit). I have Microsoft Word previews turned off because of the issues I was having with Dropbox cloud-only files.

So I suppose the question (more accurately) is... Why is it with the preview handler disabled, is DOpus deciding to open the file instantly?

Having the Word viewer turned off explains why the document is viewing in Explorer but not Opus.

Are any of the other viewers assigned to the extension? If the MS Office (Legacy) viewer has been turned on (lower down the same list), that could be what's opening the file.

Just checked. It's not under Microsoft Word (legacy), but it is also under ActiveX Generic (32-bit).

Take it out of there and I expect it will fix the problem with the file opening.

I'll update the defaults as well, since it won't do anything useful down there these days. (It dates back to the brief period when Open Office came with a viewer, before they gave up on such things.)

Voilà! Merci beaucoup.

1 Like