OneDrive Icons

Hi, I am missing my onedrive icons (green dot, blue sync, red not synced). How could I get these back

Try turning on the General > Status Icons column if it's not already on. That may be all you need to do.

OneDrive should be auto-detected, if you're signed into it. If it isn't, you can add it to the list of cloud folders under Preferences / Folders / Special Folders.

Turning on Preferences / File Display Columns / Options / Display extended sync attributes for cloud folders should enable more detailed attributes (but can cause problems on some Windows versions, depending on what Microsoft have broken or fixed lately, so turning it off can help in some situations as well).

I tried all three options but still cannot see the OD icons :frowning:

Do you have the status icons column turned on? (In the file display. The Prefs screenshot with it ticked is just changing the column's appearance, not whether or not it appears.)

Yes, it's turned on. The symbol is there in the column but not in the icon of the file which is what I would like (and had before)

I even set the registry (based on the Windows 10 recommendation)

Oh, if we're talking about overlays, there's one more setting that may be involved:

Preferences / File Display Columns / Icons / Show cloud storage icons in the Status column

I would use the Status Icons column instead of relying on overlays. Overlays don't work properly in Windows as there's a tiny per-process limit to how many there can be and the slots may be used by something else if it gets in first. The column an also show more information than a single overlay can.

I don't think this aspect has changed since Opus 12.

I moved the status icon column to the front for now. I personally like the overlays and got used to them somehow. Tried your suggestion and does not seem to work for me