"open with" to load image in Paint.NET no longer working

I cannot open images with DOpus in Paint.NET over the context menu. But other programs like Affinity still work. Also Windows Explorer can still open images in Paint.NET so it's only something with DOpus and Paint.NET.
Paint.NET recently switched to the newest version of the .NET framework. I think that is, when it stopped working.

Paint.NET isn't registering itself properly, which results in the program being run but not passed any file path to open:

It should have a %1 in there somewhere to insert the file path, like this:

There's also a second, correct registry entry for the program but we use the first one and ignore the second as a duplicate. I'm guessing it works in File Explorer because they ignore the first one and use the second one instead.

While it's not our bug, we should be able to add a workaround for it fairly easily.

1 Like

A workaround has been written and will be in the next beta.

You can also fix things on your own machine by changing (Default) registry value under


(see my first screenshot, above) to this:

"C:\Program Files\paint.net\paintdotnet.exe" "%1"

(In other words, add quotes around the path, and add "%1" to the end.)

Thanks for the effort, really appreciate it. I will write a bug report for Paint.NET or have you done that already?

I haven't reported it, no. Adding the workaround was easier. :smiley:



The problem I am having is that when I right-click on an image file (using DirectoryOpus 12.27 x64) and then choosing Paint.net it will open the file twice inside Paint.net.

I already uninstalled Paint.net and cleaned the registry and all remints of the program and then performed a clean install. The problem still persists.

I have other file managers (including the Windows default one) and all of them work fine, Paint.net only opens once the one image file selected with the "Open with...". Only DirectoryOpus is making Paint.net to open the file twice.

Any ideas?

By the way, I went to all registry entries I could find and the "%1" is there in all of them.

It does not open twice on my computer.
I'm using Windows 11 and the MS Store version of Paint.NET. Everything is on the latest stable version.

It looks like the original issue was fixed in Paint.NET version 4.3.1.

Fixed an issue with using Explorer’s "Open With" menu on Windows 7, 8.1, and some editions of Windows 10

Maybe the workaround in DOpus now causes problems for the installer version?

The workaround wouldn’t cause that. Sounds like a bug in Paint.Net if it’s opening the file twice. Opus would only run it once.

Win10 w/ paint.net 4.3.10

Issue occurs on my system with DOpus only, as well. Going through File Explorer works as normal. Not sure this is a paint.net issue...

The issue could be with Paint.net or Dopus or both.

The issue only happens with Dopus, however.

I have Total Commander, SpeedCommander, FreeCommander Xe, plus the Windows File Manger and the issue DOES NOT happen with them.

So, I am more incline to believe that it is more of an issue with Dopus, unfortunately.

I tried in different machines, some with Windows 10 and other 11, and it's the same across.

NOTE: I downloaed Paint.net from their website directly. I have not tried from the MS Store.

When did it start happening? After Opus or Paint.Net was updated (or both)? Have you tried going back to previous version(s)?

I didn't notice that.

I sort of updated both whiting the same week though. I just didn't open any images immediately. A week later after updating them both is when I noticed.

If it is Paint.net, then why it is only affecting Dopus. All other file managers I have installed are working properly.

Question, is there a way to add a context menu entry to those shown by Dopus? I say this because I've notice over the years that Dopus shows a lot more context menu items than even the Windows default File Explorer. Or is there a way whiting Dopus to edit the context menu items shown while using Dopus?

If it's Opus, why is it only affecting Paint.Net? :slight_smile:

Working out which update to which program caused it would make the most sense here, especially when it isn't happening for everyone.

Settings > File Types.

Thanks Leo.

I went into the settings > File Types and made some "sort of logical" edits in there but nothing. I left them with the "Default" settings in the end.

However, I decided to implement another way around the problem. What I want is to be able to right-click on an image (anywhere in the hard drive or any storage device) and then be able to select Paint.net to open that file. So, since "Open with... Paint.net" is not working properly, why not make a new Context Menu entry all together?

These are the steps.

Step 1 - CRUCIAL
Find the Paint.net installation folder path. In my case is: C:\Program Files\paint.net

Step 2
Open "Notepad" or another text editor and paste the following:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Open with Paint.net]
"Icon"="C:\\Program Files\\paint.net\\paintdotnet.exe"

[HKEY_CLASSES_ROOT\*\shell\Open with Paint.net\Command]
@="C:\\Program Files\\paint.net\\paintdotnet.exe \"%1\""

Step 3
Save the file with any name you want to your desktop or any folder. For example, file name: "Paintdotnet fix reg code" Note pad will make this into a .txt file.

Step 4
Using (you guested it!!!) Dopus, change the file extension of the file from ".txt" to ".reg" and the new file name should read: "Paintdotnet fix reg code.reg"

Step 5
Double click on the registry file to import the contents into the registry.

Step 6
Using Dopus or any other file manager, go to an image file and right click on it, then you will find "Open with Paint.net" right there (somewhere in the Context Menu - for me it shows towards the bottom) and no need to go into "Open with..."

Now Paint.net opens the file only once!!!

If you installed Pain.net to a different directory/path, then simply modify the text above to reflect that. For example, say you installed it to this Path: C:\Programs\PaintDotNet Then the registry file will be:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Open with Paint.net]

[HKEY_CLASSES_ROOT\*\shell\Open with Paint.net\Command]
@="C:\\Programs\\paintdotnet\\paintdotnet.exe \"%1\""

NOTE: Notice that in the Windows Registry, folders use TWO back slashes \\ for the path.

This solutions saves me a second not having to go an extra step anymore (into "Open with...").

I almost forgot to mention that this registry fix (above) will only work with a Windows Administrator account.

For a "User" account, this should work (this one I have not tested though):

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\directory\shell\Open with Paint.net]
"Icon"="C:\\Program Files\\paint.net\\paintdotnet.exe"

[HKEY_CURRENT_USER\Software\Classes\directory\shell\Open with Paint.net\Command]
@="C:\\Program Files\\paint.net\\paintdotnet.exe \"%1\""

Don't forget to make sure the install path is correct, or modify it if you need to.

I was able to reproduce the issue today and we'll have a fix for the double-open in the next update. (The issue will only happen with the latest Paint.Net and Opus versions combined.)

1 Like


Those are AWESOME news!!!

Thank you so so much.

1 Like