Open WSL folder may change folder tree

I added the home directory of my WSL into favorite for quick access, the path is something like \\wsl$\Ubuntu\home\my_username. In the pic below, I can still see "This PC" and all my local hard drives.

Once I click on one of the WSL folder to open them, the folder tree changes to "Network"

This is annoying. The only way to bring the folder tree back to local disks is to click on another local folder in the favorites, such as Onedrive, and the tree will update itself back with "This PC"

I know this is probably because WSL2 is now a virtual machine over local network. Is there a way that the folder tree will not be updated as "Networks"?

It's considered a network folder since it's using a UNC network folder path. (Same as \\localhost\xyz is a network path even if it points to the local machine. It still goes through the Windows network stack and Windows APIs will consider it a network path.)

You've also changed the Folder Tree's "Start In" setting from "Desktop" to something else, so the tree won't be showing all the top-level branches at once, and will switch between them based on the current folder. If you change it back to "Desktop" it should work better for this kind of thing.