Open .zip archive from browser

I use DOpus with two listers layout.

After a downloaded .zip archive is opened from internet browser (ffox or chrome, it's the same), another DOpus view is launched (as DOpus is my default viewer for zip archives), again with two listers.

Would it be anyhow possible to configure DOpus to open such archive in a new tab in existing DOpus view/instance?


Yes, just turn on Preferences / Launching Opus / Explorer Replacement / Open external folders in a new tab.

Hm, that would be it if I would use DOpus as explorer replacement. But I don't.

Any suggestions (except for the obvious)? :slight_smile:

That setting also affects launching zip files if Opus is the default zip handler, even if Opus isn't the default folder handler.

You'll need to select one of the Explorer Replacement options temporarily, to enable the checkbox, but you can go back to having Explorer Replacement disabled after turning on the checkbox; it still takes effect.

:smiley: I'm sure you're aware how strange that sounds...

However, it works for me! Thanks!

We've put in a change for the next version so the checkbox is always enabled. Disabling it when Explorer Replacement was disabled is a left-over from before the option also affected zip files.

This does not work any more for me - now DOpus is the only archiver on my PC and nothing happens when I double click an archive in explorer or browser. Icons are correctly assigned, though.

If it used to work and no longer does, after you've removed other archivers, then one of them probably messed up the filetype registry settings.

Try turning off Preferences / Zip & Other Archives / Zip Files / Make Opus the system default handler for Zip files (if it's currently on), then Apply, turn it back on and apply again. That should re-write the registry settings, unless they're messed up in some other way.

Hm, I have done so already and still nothing.

I've just noticed that none DOpus .zip commands work from explorer - I've tried with extract and open with dopus helper application.

However, extract shell command does work from inside DOpus!

Any advice?

Please run FileTypeDiag on the .zip extension, zip the result and send it via an attachment or private message.

Thanks for the log file.

Did you launch Opus as admin (i.e. elevated via a UAC prompt) by any chance?

Have you tried rebooting and then double-clicking a zip file?

Yes, DOpus is launched as admin (set in compatibility options).

It's not convenient for me to reboot right now, but, I've restarted explorer process and no change.

Please see Why NOT to run Opus as Administrator under UAC for why that's a bad idea.

Oh, it's much better now, thank you!

I don't really remember any more why I had to turn it on (I don't normally check that option without a reason).

P.S. Why 'DOpus helper application' doesn't warn about this?