Opening an archive replaces all open tabs in lister

I've had this issue with 12 and it's back in 13 beta despite not transferring my settings. Basically often when I download a zip file and click on it from browser's download panel, it will open in DO, but it will be the only tab, making me lose my 10+ open tabs. And then when I quit the setting to save lister as default remembers that I closed all my tabs.
I have to have a separately saved lister layout as a backup for when this happens. How can I fix this behaviour?

Try checking Preferences / Launching Opus / Explorer Replacement / Open a new tab instead of a new window.

It is enabled already.

Try turning off Preferences / Zip & Other Archives / Zip Files / Enable internal Opus Zip support, then click Apply.

Verify that opening a zip the same way as before now opens it in something other than Opus. (If it still opens in Opus, that could indicate the problem as something external to Opus may be overriding the file type and running the wrong command.)

Then turn it back on and click Apply again. That should ensure the relevant registry details are appropriate for the other options you've chosen.

If it still doesn't work after that, please go to Settings > File Types, open the menu and select Diagnostic, then enter .zip and attach the result (or send it via PM):

Thank you, it makes no effect and I sent you the zip.
Actually when I installed 13 I had troubles with zips not opening in Opus at all (even had a thread here - Opus not opening rar and 7z archives when they are opened from elsewhere - #2 by Leo )
So I borrowed from the forums - File Types > Zip > Commands > open > "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /cmd go "%1" newtab=findexisting

Maybe it's the issue.

Also when I have lister opened it opens normally as a tab. If all listers are closed then this issue happens.

Change the newtab=findexisting to newtab=findexisting,deflister

1 Like

Seems to work, deleting that command completely fixed Firefox, but not Chrome (stopped opening in dopus completely), but with deflister both browsers work fine. Thanks a lot.