GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Opening file with incorrect program on double click


#1

I tried to open a .gitignore file by double clicking on it. My default program for this is VS Code but Notepad was opened instead. If I right click > Open it opens VS Code as expected.

I am using Windows 10.


#2

If you set VS Code as the default text editor under Preferences / File Operations / Double-click on Files, does the desired program open afterwards?


#3

It does. Thank you. I wasn't aware of this setting.


#4

Glad that got things working!

If you want, and have time, we can look at why it wasn't picking up the default for that type automatically. To do that, please go to Settings > File Types then use File > Diagnoistic at the top-left of the file types dialog. Generate a diagnostic for the .gitignore extension. If you send that to us we can take a look at what was happening.


#5

Here you go.

Opus_FTD_File_gitignore.zip (43.6 KB)