GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Opening tab group, opens a tab that is not part of the group

Hi,

I currently see a strange behavior of DO (12.19 x64, Win 10 Pro) when using a tab group. This group is defined like

Short story: right after selecting and applying the tab group, one of its tabs immediately switches to a different content. In this case to the File Collections.

This is reproducible when following those steps:

  1. Exit every instance of DO (maybe not necessary)
  2. Restart DO
  3. Open the tab group "Scribe SAP"
  4. Focus any tab in the e.g. right lister: "05_Phoenix" (same for the left lister, btw)
  5. Select the File Collections (or one of its sub collections) from Folder Tree to display its content in e.g. tab "05_Phoenix"
  6. Re-apply the same tab group "Scribe SAP"
  7. Now I see the described behavior: First, all defined tabs are shown, but one of the tabs (mostly the first one on the right side) immediately switches the content to the File Collection (or sub collection), without any further action on my side.

According to the tab group definition in image above, I would assume that after selecting the tab group, all previously opened tabs are closed and the defined tabs are displayed.

When selecting the tab group again after this has happened, all runs well. The behavior shows up when following the steps above again.

At least, this always happens, when I change the content of one of those tabs to File Collections and re-apply the tab group.

Btw, no folder lock is used. Neither in folder tree nor in any of those tabs from the group, if this matters.

Edit: when selecting one of my other tab groups instead of the same in step 6) this too happens to me. Hence, I guess it's not an issue with a specific tab group but a general one?

Is this a mis-configuration on my side or perhaps an issue in DO, maybe intended behavior as such?

Michael

Do you have any scripts installed? (Preferences / Toolbars / Scripts)

Tabs shouldn't change folders by themselves, but a script could cause that to happen.

Yes, two scripts:

  • HashCompare - available from the community here
  • Macrium Backup shell folder extensions

Anyway, I've disabled both and restarted and still see this behavior.

I've created a short video shat shows whats happening and uploaded it to OneDrive. I've sent you a PM with the link.

@Leo any chance you already had a look at the video I've sent you?

I've tried for a long time but haven't been able to reproduce this yet.

There are some interesting things in your video, though. I can't see which drives/servers the various folder tabs are pointing to so I am not sure exactly how to recreate what you're doing, but I noticed some unusual things involving the folder tree.

  1. The tree is locked, which is unusual/uncommon. In that state, the tree should ignores folder changes and the collection you selected in the tree remains selected. If something is causing the tree to act like the selected item was clicked again, that would cause the collection to be loaded into the active folder.

  2. The tree is set to start at Drives rather than the normal Desktop setting. That means it may need to add and remove branches of the tree dynamically, depending on which folder is active (i.e. if the folder is in a branch outside the Drives branch, e.g. Network). Since the tree is also locked, those branches aren't being added/removed as far as can be seen in the video, but maybe it's happening behind the scenes and only momentarily. Not sure, though, and I can't make it happen here.

  3. For all the folders shown in the video, none of them cause the tree to indicate the current folders are below any of the branches it is showing, except for the collection you clicked on. The collection is the only one which gets a colored line drawn down the tree to indicate the active folder's place in the tree. Even a locked tree should do this up to the locations it is displaying, stopping at a parent of the current folder if it doesn't go all the way. That suggests the folders you're going to (other than the collection) are outside of the branches shown in the tree, although I can't tell for sure as the paths are all too long for the location bar to see where any of them start from.

If you unlock the tree does the problem still happen?

Or if you set it back to the default Preferences / Folder Tree / Contents / Start Folder Tree At: Desktop mode?

What if you close the tree entirely? Does the problem still happen then?

Are you able to make it happen with a simplified tab group that only shows a few short paths on local HDDs, or does it only happen when some or all of the paths are in more unusual locations (e.g. mapped network drive letters, or UNC paths)?

Hi @Leo

Yes, since I've locked the folder tree, switching those tabs does not focus the folder tree. Most of those tabs are located on a network share without a drive letter.

Yes, it still happens.

Issue still happens, no matter if I start with Drives or Desktop.

When closing the tree folder, I cannot select one of the file collections to simulate the issue again.

Will do this, today later on and report back.

Thanks,
Michael

Here's one way to navigate to file collections without the tree being open:

Hi @Leo!

Thanks for your reply! I've closed the folder tree and tested this scenario, too. The described behavior still occurred.

BUT, following your next advice, I've created a new tab group using local paths only and tried to reproduce the issue. Good news: nothing happened. The first tab did not change now!

I then added a new tab to the group, using an UNC path to a network share. This tab was placed to the end of the right lister. I still could not reproduce the issue.

However, I now moved this UNC path tab to the first place of the right lister and retried. Guess what? I now could reproduce this issue as described in my first posting.

Further tests revealed, that using a mapped network share, did not change the game. E.g. let the first tab pointing to network share which is mapped to drive letter H:\ for example.

Those shares on PC A are pointing to a Microsoft Server, I guess, I can say for sure that it's not a Linux server. But I do not know which enterprise storage is running in the background.

My PC at home again is using network shares, mapped to drive letters. But I cannot reproduce this issue there. Only difference is that at home the shares are pointing to a Samba driven NAS (Synology). Don't know if this is of any relevance to you.

cu,
Michael