GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Opus 11.12.1 and Meta data


#11

Video of what happens
dop(2).zip (3.45 MB)


#12

The enclosed screenshot shows what happened when I tried to add metadata to a field using the latest version of Opus. It may give a clue as to what is going on.



#13

Looking at the video, you're clicking on the line you are editing to apply the change, which I think is confusing Opus because that makes you start editing the same line again, and the change is never applied.

If you click almost anywhere else, before clicking Apply, does it work?

Looking at the screenshot, I'm not sure what is meant by a "white icon appeared". I can't see a white icon anywhere.


#14

I see where you are coming from, but I have always worked like that and it makes no difference if I click on another field before applying metadata changes.
The white icon I am talking about is the first icon on the top row called 02jpg7620.

I had a similar sort of thing a few months ago when trying to change metadata on PSD files, but you fixed that.

What I would say is that if I go back to the previous version everything works fine.

Also could you tell me which IPTC field is the equivalent of the the Opus Subject field?


#15

What happens if you click to the right of the field you are editing, instead of on the left of it?

Or, just push Return after typing the change, before clicking Apply.

You want to make sure the edit box you were typing in goes away when you click. If the edit box is still there (which will happen if you click on the left where the red arrows appear), then it might be what's causing the problem. (This is just a theory at this stage.)

Please also try turning off the checkbox next to the Apply button, in case that is related. The 002.jpg7620 file looks like a partially-updated version of the file which is left when writing the new version, or replacing the old version with a new version, fails for some reason. Maybe the issue is tied to clicking Apply when automatic application is also turned on, and Opus is trying to update the file twice.

We should be able to fix whatever is happening, but we need to make sure we understand where it's going wrong first.


#16

Follow-up to previous post: Please also try fully exiting Opus (via File / Exit Directory Opus) to see if it starts working again after a restart. (Don't just close the window, as it will still be running in the background. Use the explicit Exit option, please.)

I think I just reproduced the problem, but it went away again after I did this, and I'm now no longer able to reproduce it again. There does seem to be a problem here somewhere, but triggering it seems to need something specific that we need to nail down in order to understand what's going wrong and fix it.


#17

I tried all the things you suggested in your last two posts.

Whatever I do I get the same problem. The modifications I make appear in the box but when I apply them the box is filled with the pre-modification data.

Quitting and re-booting made no difference. I had already tried this.

It does seem a little more than a co-incidence that the new beta version contains alterations to link Opus and IPTC data more firmly.
Thanks for your efforts


#18

I select a .jpg and press Ctrl-M and the metadata window appears.
I can edit existing fields and the changes are saved, no crash.
I can edit empty fields - except Authors - and changes are saved, no crash.
If I edit the currently empty Authors field at the top, crash every time with error 0xC0000005 and offer to terminate thread.
(Edited by typing into the field, press Return and red triangle appears, click OK at bottom)

bob


#19

Also happens with the Tags field, but no others that I've noticed.

bob


#20

@comtrjl: Thanks for the report! I can reproduce this, and it will be fixed in the next update.


#21

If I look at the metadata of files changed on my system which results in the creation of a white Icon instead of the proper file, I see that only the extended and standard properties have been saved. Perhaps this is a help.
002.zip (296 Bytes)



#22

What happens if you give that file a .jpeg extension?


#23

No change, I am afraid.


#24

We have released a new beta (11.12.2) which has some debugging output in it that will hopefully tell us what's going on.

[ul][li]Download the new beta, install it and make sure you reboot if needed[/li]
[li]Download DebugView and run it[/li]
[li]With DebugView running, use Opus to try to modify a metadata field as you described previously[/li][/ul]

You should see a line appear in the DebugView window similar to:

There will probably be other messages that appear as well but the only relevant ones will start with dopus: Exiv2:. Please copy and paste any such error messages and hopefully we'll be able to work out what's going on.

(This new beta also fixes the crash with the Authors/Tags field reported in this thread).


#25

Here is a zip file of the debug output, that you requested.
DebugView output.zip (406 Bytes)


#26

Please try the 11.12.3 beta and let us know if it resolves the issue.


#27

Initial tests show that this is a fix for the problem I am experiencing. I will continue testing and let you know if I have any other problems. Many thanks for your efforts.


#28

One small niggle with the metadata fix: If the Description Subject and Title field are all empty and you enter metadata in the Description field, the metadata is entered into the Subect and Title field as well when you save.
Whilst there could be an argument for this happening with the Subject and Title field, it is very inconvenient when you simply want to add a Description to an image.
The compatibility with IPTC fields a great step forward, however.


#29

Thanks for that. The erroneous fields are coming from Explorer and aren't actually written like that to the file. We'll fix this in the next version.


#30

This should be fixed now in the 11.12.4 beta.