Opus opens when double-clicking desktop icons

After upgrading from 12.22 to 12.23, a very strange problem has arisen. If I dbl-click any icon on my desktop, a dopus lister appears as if I had dbl-clicked in an empty area. Tried restarting etc, no change. Needless to say, if I terminate the dopus processes, dbl-click is fine again and opens my files. For now, I'm back to 12.22 and all is good. Any idea what causes this?

Does it stop if you turn off Preferences / Launching Opus / From the Desktop, and come back if you turn it back on?

Are you using anything else which adds double-click actions to the desktop (Display Fusion is one popular example), or which changes how the desktop icons work (Fences is a popular example)?

(We don't know of any issues with either program, but it's worth considering if something strange is happening.)

Which version of Windows are you using?

Hello! Sorry for the late reply
I'm on Windows10 Pro x64 latest update
Now, I've reinstalled 12.23 and suddenly it worked. For a while. Same behaviour after a couple of sleeps and wakes of my pc, so, sure enough I disabled the launch from desktop, re-enabled it, and it worked again for a while, then the same. Went back to 12.22. After all, that wasn't a solution either, after a while the same behaviour began and it was temporarily solved by disabling/enabling said setting, it just took longer to appear.
I do have installed both those programs (Display Fusion and Fences). I disabled Display Fusion and nothing changed. I'd have to uninstall Fences to see if that's the culprit, cause it basically can't be disabled (even tried some reg files). Thing is though, haven't touched fences for months now and never interfered with DOpus. How do you suggest I 'd proceed from here on?

In truth, I've never actually went back to 12.22. All the setup files I download from the blog (stable or beta) are 12.23 and I simply hadn't noticed. So, I guess that's why the solution was always temporary, it simply restarted Opus and seemed like it worked.

I'm not sure what would cause that. We don't do anything different over time, so some other software must be updating or restarting itself, perhaps, and then interfering with the desktop double-click hook.

I'd try uninstalling both the other programs temporarily to see if either makes a difference. (Disabling them may not be enough as the hooks may still be active and just set to not do anything.) If it turns out a particular one is involved, that gives us a more focused direction to look in. If not, I'm not sure what else it might be.

Nothing related to this changed in 12.23, as far as I can see. I don't think the desktop double-click code has needed any changes in a long time.

I see, I'll try with them uninstalled. In any case, is there a place I could get 12.22 to test in case that fails?

We can provide the old installer if needed, but I'd be surprised if a recent Opus update was the difference here.

Hello again and a happy new year. Finally got around uninstalling everything from stardock and displayfusion today and the problem reappeared regardless. So, could you please provide a couple of older dopus versions to try out?

Here's 12.22: https://leo.dopus.com/temp/DOpusInstall_12_22.exe

Thx, I'll report back after I try it

I came here to chime in that I, also, have been experiencing the problem where double-clicking on the desktop icons (Windows 10 Enterprise 1909, DOpus 12.25.1 x64) causes the default lister to open instead of the program or file associated with the icon.

I saw Leo mention DisplayFusion which is something I used in the past, but is no longer installed. But I explored further and found out that my issue was apparently being caused by WinSplit Revolution (an app for quickly placing windows in various configurations), specifically the "drag'n'go" functionality. If I disable that function or exit WinSplit Revolution, the double-click behavior is restored to the correct behavior.

Interesting, and I'm glad I figured it out because it was pretty annoying.

1 Like