Opus won't drop a drive letter for a removable drive

I've just had to do a clean reinstall of Windows XP, and on opening the newly restored Opus, I've noted an odd problem. If I attach a thumb drive, which, say, becomes J:, on removal Opus won't drop the J: until I reboot. Even then, it shows J as unavailable in the location bar.
Similarly, if I use Disk Manager to change, say, the drive letter of an attached disk from J: to K:, then Opus will still show J: as an unavailable drive. I then can't use Disk Manager to assign J: to a new drive, even though DM doesn't show a J:.
It never used to do this! Help


i have a somewhat similar issue- when i mount an encrypted drive, it does immediately show up in d.o. but then when i go to unmount it, it wont let me do so. i have to exit d.o. and then unmount the drive, and restart d.o.

dchainey, do the drive letters also continue to appear when you go to My Computer? I think Opus just gets a list of drives via a Windows API so it seems strange that only Opus is still showing the drive letter.

No, neither My Computer or Disk Manager show the drive letters, although they must be in the Windows API, as DM won't let me reuse them.


Tried exiting and restarting Opus? (Exit it via the tray icon's menu; just closing all listers won't exit the program.)

When you remove the drives are you using the Safely Remove Hardware icon (or Eject from the device's right-click menu) or just pulling the drive out?

Although it's gotten better with the last few updates, Opus (or perhaps one of the viewer plugin DLLs or shell extensions it loads) does still seem to hold locks on removable drives sometimes. Some people experience it more often than others. (I get it very occasionally and for the life of me can't work out what triggers it or a reliable way to reproduce it on my system.) I've not heard of it doing what you describe, though; when it happens it's usually like what der_affe describes, where you cannot "safely remove" the device without exiting Opus, but once you do and remove/eject the device the drive letter goes away normally. The two things may be related or they may be totally different issues.

Maybe Explorer sees the device the same way Opus does but it also has some logic to filter out devices in that state.

I tried the safe exit (must admit I don't usually bother with a USB drive), and exiting DO from the tray. Neither had any effect. The K: (what the USB was) only disappeared on reboot.

Dave C

From further investigation it looks like the problem (from the top post) is not due to Opus since it happens even if Opus is set not to run on startup and is only launched after the device has been removed.

Opus is showing one of the symptoms of the problem, the "stuck" drive letter, but can't be the cause since it doesn't have to be running for the problem occurs.

Perhaps Opus should filter out a drive marked "unavailable" although that would only be hiding the problem and not fixing it.

I have exactly the same problem. First I thought it was my drive, but it happens only on those pc's with Dopus on it ... since the installation of this version.

I emailed the manufafturer of the drive (WD) and Dopus. WD's diagnostic software cannot detect any problem. Dopus replied but denies any cause on their end.

Note, my WD external drive is fully compressed.

Note, I recently installed Yahoo Desktop Search, Yahoo Widgets, Rainlender, Rainmeter, Synchback (by 2brigthsparks), and Registry Mechanic. Maybe there is some interaction problem going on between these programs and XP.

You have to separate the two problems in your mind.

Yes, Opus seems to show drive letters that Explorer doesn't. Not sure why - haven't looked into it yet. But this is not the real issue.

The real issue is, why are your drive letters being left behind in the first place? I've had email conversations with a few people who have had this problem, and they have all found that the drive letter duplication happens even if Opus is set to not run on startup, not replace Explorer, and has never been started.

That is, they reboot, insert the USB drive, access it with Explorer, remove the drive, and reinsert it, and it gets a new drive letter. Opus is not and has never been run - therefore, there's no way Opus can be responsible.

So yes there is the problem - albeit a minor one - of "old" drive letters being shown in Opus when they are hidden in Explorer. But the underlying problem - that causes the drive letter duplication in the first place - is something else and you will need to track that down yourself.

Thank, I'm trying to find a solution by eliminating the usual suspects. I found it strange that this problem occurred just after having installed the latest update of Dopus.

Somehow XP has been affected by a program and I'm trying to find a solution. So, any help is welcome.

Interesting. The only programs we have in common are Registry Mechanic. I wonder if that's the problem? I did have Yahoo Widgets installed, but had to uninstall it because of problems. Yahoo programs do tend to hang around though, so that could be another culprit.



I installed Registry mechanic after the problem occurred. It could be yahoo ... I'll report back with any news on this.


Nope, that does not help either. What about Apple Ipod software and quicktime?

Actually I ran into the problem first of all after a clean install of XP, and I believe all I had installed when I first noticed it were XP, Zone Alarm, Spyware Doctor and Dopus.
I don't think I have any iPod software installed (I don't own one), but I do use iTunes, and therefore have Quicktime, and anything else it intalls, by default.


Spyware Doctor ... I'll delete that one too!

How are you guys going with this?

Still no progress.

Did you try removing Spyware Doctor?

If you do a Google search for Spyware Doctor drive letter then you'll find at least two threads where people say the program causes this exact problem and removing it (not just disabling it) made the problem go away.

Seems pretty conclusive.


discussions.virtualdr.com/showth ... p?t=205616

[quote]Well, it looks like I have found the cause. It is caused by Spyware Doctor, I have mentioned earlier in my posts. It's just that disabling it is not enough. When I've removed (uninstall) it from my system the problem has gone. Also I was able to reproduce my problem on other computers just by installing Spyware Doctor on them. Right now support guys are dealing with this.
Thanx for your time.[/quote]
There are also threads where people mention the problem and that they have Spyware Doctor installed but haven't made the connection yet, plus some with second hand reports that the program causes this problem. I get the impression something got broken in an update so hopefully they can fix whatever that was but for now uninstalling the program seems like the solution.

Thanks a lot, I was just about to take out Spyware Doctor.

My take away from this is: it helps if people mention the software they installed recently. That's how we singled out Spyware Doctor.

Maybe a tip for posting on the stick-notes part of the forum.