GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Phrase input

I have set the filter bar to the default mode. For the first search in the tab, the filter bar cannot receive the entire Chinese phrase, but only the first word of the phrase. After the mouse clicks on the pattern field once, or the second time, the Chinese phrase can be completely received, and the search input box of Settings > Preferences is also the problem.

How are you typing/inputting the phrase?

There are many files with Chinese names in my folder, such as xxx财务报表.doc. After I click on the tab of this folder, I type "财务报表"(Financial Statements) directly. The pattern field on the filter bar only displays "". I have to enter the "务报表" again. But after I clear this input, the pattern field can receive the words "财务报表" at once.

The English words are the same. I use the input method tool to type "photo" and the pattern field only receives "p" for the first time.

After deleting the first letter entered, the pattern field can receive the words and phrases in its entirety.

这应该是你输入法的问题,我使用win10自带的拼音输入法没有这个问题。

肯定不是输入法的问题,我加上微软拼音也是一样。是过滤器栏设置成默认模式才产生的问题,用*调出来就没有问题。搜索和查找设成默认模式就没有问题,能直接接收任意长度的词组。

@Leo It is normal that search and find are set to the default mode, they can receive phrases of any length, only the filter bar can not.

What are your settings?

Do you want to use the filter bar or the FAYT field when you type characters?

This is my settings,

I want to use the filter bar, the FAYT field is all right in this case.


Find and search can receive phrases of any length from the beginning. If not, it will affect the efficiency of the search.

Seems fine here with the same settings.

But from your last gif, it looks like you're typing into some kind of non-standard IME or similar, or maybe a tool for augmenting file managers or something? The thing with the S in the corner which you actually type into. That isn't part of Opus and doesn't look like part of Windows either.

You observe very carefully, this is the Chinese input method tool I have to use every day. The entire phrase can be entered at one time, including Chinese and English. Find and search can completely receive the phrase it typed in the default mode, and the filter bar can also receive it when it is not in the default mode.

That tool is probably sending all the keypresses to the control it is triggered in.

But the filter bar doesn't exist yet. It's created when the first keypress happens. That keypress is forwarded to it, and it is then given focus so it receives any subsequent keypresses directly.

The IME must be sending all the keypresses to the initial control, which is the file display, instead of letting each keypress go to the control with focus.

Maybe we can add a workaround for that, but I'm not sure how we could test it in order to write the code.

I seem to have found the reason. The filter bar may rarely be set to the default mode, it may have been waiting for a character * to appear. I set the filter bar to the default mode. It may still be this state. The first time it only receives one character, even if it is not *, this will explain the phenomenon I encountered.

In the code, you may just skip the initial firing condition of the filter bar in the default mode, or refer to find and search, and put everything received by Opus into the pattern field, not just a character.