Picture viewer : how to fit with the screen

Good morning,

I wanted to do so that every picture does fit the best with the screen and I thought I did the correct thing when I did : Edit - Preferences - Viewer - Appearance - Auto-size viewer window --> To fit every picture

However, I still have the problem when I come to a big resolution picture that it does not fit with the screen automatically. How should I do this please ?

I think you might need to change: "Prefs/Viewer/Behavior/Reset zoom level for each picture to:"

You're perfectly right, many thanks Steve.
A last question I have for the moment. Sometimes when a pic or movie is selected, it opens a preview beside the file explorer and I don't want it to be launched by default. Here again, I didn't find the right parameter to change. I guess it's something in Viewer - Viewer pane but I'm not sure what :confused:

Not sure what you mean by "I don't want it to be launched by default"? Do you mean that when you select a file in the Lister you don't want the viewer pane to show that image immediately or do you mean something else?

If you mean you don't want the movie to automatically play, then go to "Prefs/Viewer/Plugins", then select the movie plugin and click the configure button. Then you can toggle off the "Automatically Play Movies" option.

Sorry if I was not clear. Well, I just don't want the viewer pane to open at any time and sometimes it does (I could not find yet when it happens). It does not open by default when I select a file, but sometimes after I doubled clicked on an image or a movie to launch it with my default program (VLC for movies, DO viewer for pictures) and when I close the VLC or DO viewer, right after, the viewer pane opens and shows the picture or launch the movie. Do you suggest me to uncheck all the plugins so that it does not happen for any kind of file then ?

Shouldn’t be a plugin that opens it automatically.

I’ve not seen that happen. Perhaps Leo or Jon will have an idea where to start looking.

It might be useful to post a video showing this happening if you can.

There's no way that selecting a file will turn on the viewer pane (outside of obscure things like mouse driver macros etc.).

Is the viewer pane already turned on but blank before you select things?

"Is the viewer pane already turned on but blank before you select things?"
Anyway, I have now put DO in French which will help me understand better the parameters.
Thanks again for giving your best promptly to help me, much appreciated :slight_smile:

Dear Leo, I think I spotted when the viewer pane opened without wanting it to happen.
I have parametered my keyboard so that F7 opens a specific folder. Is it possible that F7 is also a function to launch a pic/movie file in the viewer pane ? If so, where could I remove this shortcut (and see the list of existing shortcuts in DO) ?

Thanks in advance,

F7 opens the viewer pane by default.

Help > Keyboard Map lets you see and edit hotkeys.

(Settings > Customize Toolbars > Keys goes to the same place, as an alternative.)

Many thanks Leo, so complete and prompt to reply ! :+1:

Hello, I've just changed my PC and restored my configuration that I had saved from my previous one. I could verify that "Prefs/Viewer/Behavior/Reset zoom level for each picture to:" is still selected. However, it does not work. Small pictures are shown small, not zooming to fit the screen.
Any idea how to solve this issue please?

Sounds like it's set to Fit To Page, not Grow To Page.

Awesome, you got it! Many thanks for all Leo!