"Pin to Start" not working on Windows 10 x64

I'm having a problem with the "Pin to Start" context menu command not working. I first tried the File Explorer added context menu entry, but when I click on it nothing happens. I tested it from File Explorer to make sure I didn't have a system wide issue and it worked as expected. So it's only other file managers that have a problem.

So I created a button on the Context menu for the "Programs" file type group with "ContextMenu PinToStartScreen" as the command. I figured this will work seeing it's an Opus command, and I was total wrong. I click the button and again nothing happens. I also created a "Pin to Taskbar" button and that one does work. So hopefully that means that my button syntax is correct at least.

So I tried to debug it and do see an error, but I have no idea how to resolve it. It might not be a real error, I just don't know anywhere near enough to figure it out. So here is what I got from the debug. Hopefully, it means something to you.

[5300] onecoreuap\shell\lib\calleridentity\calleridentity.cpp(75)\TokenBroker.dll!00007FFCDBB8011C: (caller: 00007FFCDBB7CC51) ReturnHr(1) tid(2eb4) 80070005 Access is denied.
[5300] onecoreuap\shell\lib\calleridentity\calleridentity.cpp(75)\TokenBroker.dll!00007FFCDBB8011C: (caller: 00007FFCDBB7CC51) ReturnHr(2) tid(2eb4) 80070005 Access is denied.
[24484] AAA QueryContextMenu 1
[24484] pcshell\shell\appresolver\lib\userpinnedtilemanager.cpp(209)\appresolver.dll!00007FFCD7483F2B: (caller: 00007FFCD7484222) ReturnHr(12) tid(8fd8) 80004005 Unspecified error
[24484] CallContext:[\UPTM_CreateUserPinnedTileShortcut]
[5164] avcore\npsm\localprovider\baseprovider\lib\baseprovider.cpp(604)\NPSMDesktopProvider.dll!00007FFCAE273FF5: (caller: 00007FFCAE274730) ReturnHr(1366) tid(176c) 80070490 Element not found.

I'm running:
Directory Opus Pro 12.3 Build 6183 x64
OS 10.0 (B:14986 P:2 T:1) SP 0.0


In Windows 10, "Pin to Start" only works for things which are already somewhere in the Start Menu, which may be the problem you're seeing. It can be very confusing if you don't realise this, and the failure is silent with no indication anything failed or why. IMO it is a bug, or an incredibly poor design; not sure which, but that's something for Microsoft.

I had to create shortcuts below the Start Menu's Programs folder for some programs I wanted to pin to the main top-level of the Start Menu.

Ya, that's what I'm seeing. Totally agree with it being crap design. Well lucky for me Opus came with a "Start Menu" shortcut button so working around it is simple enough. Thanks for the quick reply.

What does this mean exactly, why did this topic end?

I upgraded Windows 10 to the Creators Update, and i wanted to pin some (portable) apps to Start like i always do (before i had Opus), but i had to use Explorer because this does not work in Opus.

Doesn't work with folders either by the way.

"Only works with programs that are already in the start menu"? It's ironic, because the goals is to add them to the start menu in the first place. :anguished:

I can add exe files or folders from anywhere just fine when using Explorer.
But i don't want to use Explorer. :mask:

Windows 10 RTM had a bug/feature where you could only Pin To Start something which already had a shortcut somewhere in the Start Menu.

For example, if you had a program that was installed and created a start menu shortcut for itself, you could right-click the same thing and Pin To Start and it would work.

But if you created a brand new .exe file which nothing had ever seen before and used Pin To Start on that, nothing at all would happen.

If you then created a shortcut to that brand new .exe under, say, Start / Programs, you could then use Pin To Start and it would succeed.

All of this was true in both Opus and Explorer, and did not really have anything to do with Opus.

In the Windows 10 Creators Update, Microsoft seem to have "fixed" this by making Pin To Start automatically create a shortcut to the .exe inside the start menu, and then it pins that shortcut to top-level of the start menu.

It clutters up the start menu but it's better than it mysteriously not working unless you work out that you have to create the clutter by hand. I guess that's an improvement ...except it still mysteriously does not work sometimes...

...Because, in the Win10 CU, Microsoft also seem to have changed another thing: Pin To Start now only works within Explorer.exe. If you try the same from, say, right-clicking a file via the File Open dialog in Notepad.exe, nothing at all happens. That is despite it being the exact same code being called in both cases.

I suspect this is Microsoft's half-baked method of making it harder for 3rd party software to pin their own shortcuts to the start menu, in the hope it will stop everything adding its own shortcut when it is installed and cluttering up the place. (They had similar half-baked solutions all over the shell for this kind of thing, and it sometimes/rarely works but always gets in the way of legitimate software and things users want to do.)

It's especially half-baked in that they still show the Pin To Start menu item everywhere (even in other instances of their own software), but have made it so it only works in Explorer.

I am not sure there is much we can do about it, but we'll take a look.

Thanks, i'll keep an eye out for it.

For me the CU probably didn't make much of a difference, just hadn't pinned anything yet with Opus before now. But i'm sure there are plenty more 'fun' changes behind the scenes for you to dive in to now.

But other than this, so far so good. Everything booted up as usual and seems to be working nicely. :relaxed:

Pin to Start will work again in Opus 12.8.2, at least with the latest Windows 10 updates (where the menu item now works again in e.g. Notepad's File Open dialog). We needed a change on our side as well as, I think, some changes which Microsoft must have made since we last looked at it.

Hello Leo - I am on 12.9 but the Pin to Start still doesn't work (it does in Explorer).

Any updates on this?


The fix is in the 12.9.1 beta release notes: Directory Opus 12.9.1 (Beta)

Note that it's only tested with Windows 10 and may not work with Windows Server 2016 (based on one report).


12.9.1 beta, Windows 10 64 bits and still doesn't work, yes on Explorer.


It's working here. Did you try pinning the same file in both programs?

Make sure Opus is not launched elevated.

Not for me. Yes I tried and only works with Explorer.

Opus is not launched elevated.

Thank you

Does it work from any app apart from Explorer? e.g. From Notepad, use File > Open, set it to show all files, and try from there.

Older versions of Windows seemed to block this (whether intentionally or by mistake) so it's possible you're sering the same on your version.

Correct. From de open dialog does not work either. But, I have every Windows 10 update, I hope it is solved in a future Windows update.

Thanks for everything

Dont want to annoy old threads, but better to make new ones i geuss, this is also not for me working sadly

It doesn't work outside of File Explorer (again). It doesn't even work in Notepad.exe. We can't fix it. Only Microsoft can.

Ok thanks for clarifying, will do in explorers it self, not a big deal