Pk3 file support

I've tried the new Opus 8 now, since I still have very fond memories about my Opus from my old Amiga days.

I have used Total Commander for years now, but would really like to get into Opus again. Its a whole new ballgame..

However, one thing I use all the time in Total Commander, is its ability to treat pk3 files as folders/zipped folders, since pk3 is just a zip file with another extension. I use it alot since I work with modding for the Q3 engine.

I was wondering if there is any way to get Opus to recognice .pk3 files as zip files and work with them, just as a folder. As it its now, I still have to use Total Commander all the time, so its hard to get used to Opus again.

Hope someone has a good idea how to do this, or maybe even has a plugin that will do the trick..

thx in advance..

In Preferences -> ZIP Files -> Settings, add .pk3 to the Extensions field. For example,


Oh very nice.. Works perfectly.. Damn.. now I don't have any excuse not to go back to DirOpus :-p

TY Jon


I've tried setting ZIP extensions to:
But, double-clicking on a Jar file does not browse as expected.
I have ensured that there is no default action for the jar file.

Any ideas?

Well, what does it do?

It seems to try to run the jar

Sounds like either you didn't remove the open action for jar files or something has restored the default.

Check both the Actions and Events tabs for the Jar filetype. You'll probably find there is an open Action which is something like this:

"C:\Program Files\Java\jre1.5.0_02\bin\javaw.exe" -jar "%1" %*

You may have to delete that if you want double-clicking to open the file as a zip rather than launch the application inside the jar archive.

Another thing you could do, if you don't want to remove the open action, is set the dblclk (double-click) Event to simply run "go". That will mean double-clicking a Jar inside of Opus will enter it as a Zip file, but if you launch a Jar outside of Opus it will run it as before, so you won't break anything that relies on the open Action.

This seems like a bit of a bug to me... If we set file extensions to be treated as ZIP files in the Dopus preferences, I would expect Dopus to automatically make whatever file type action, event, and context changes necessary for it to in fact fully treat those files as zip archives (as long as those file types are indeed compliant zip format archives of course). The only thing Dopus seems to do automatically is allow the filetype to be shown in the folder tree (if that option is also enabled) and to 'allow' internal commands to operate on the file as a zip file once we add them manually - i.e every file extension I've added to the zip extension list 'needs' the manual editing of the double click action as per Nudels suggestions. Also, there doesn't seem to be a way to manually enable the 'other' parts of Dopus zip file support for manually added extensions such as the Dopus Zip context menu...

Not only does Dopus NOT seem to set all this up by default when an extension is added; conversely, removing the .ZIP extension from the Dopus extension list does not disable the handling of .ZIP files in opus - LOL. The context menu still appears for them, and they're still shown in the folder tree. This is actually the part that bugs me just because I have chosen to use WinZip or WinRar for standard zip file manipulation because of features not offered by Dopus internal handling but would like to be able to drag, drop and extract my .DPS files to inspect and compare their contents... and can't make that happen in either of the separate zip programs. So I turn to Dopus, but I have to enable Dopus ZIP handling in order for the Copy Extract commands to work on the files and this gives me an unwanted Dopus ZIP menu on my ZIP files along with my Winzip/WinRAR menus when I right click on them.

BTW- Biiiiiig kudos for the Copy EXTRACT=sub command extracting multiple selected zip files to separate filename based folders... a feature WinRAR has but which WinZIP does NOT. You should consider adding that action to the Dopus ZIP context menu... however... another apparent bug with Dopus zip file support is that the context menu doesn't even appear when multiple .ZIP files are selected (?) unless you drag and drop... but then the only extract option is like Winzip i.e. Extract Here, where in the case if each zip archive contains identical filenames, they will overwrite each other.