Problem with Advanced FTP login - 503 Error

Just upgraded to use Adv FTP with a vendor. When I create the FTP Connection, I get a continued window showing trying to connect with an Abort option. Never completes. Looking at the FTP logs, it appears there is some success, but there's a final "503" error showing which I'm guessing is the reason the login isn't completing. The vendor doesn't mention if Passive should be enabled, but I am using all the other settings the vendor provided. Help!

The following is taken from the DO FTP log with content replaced by "x" for security purposes:

Opening Connection
220 FTP Server Ready (SSL)
331 Hello xxxxxxxxx/xxxxxx@xxxxx, please enter your password.
230-Connection established from [].
230-You are connected as xxxx xxxxx (
230 Welcome to the xxxxxx xxxxxx FTP site.
503 Expected the PASS command, not 'PBSZ'.
Timeout on Command 1001.
Connection closed

Have you tried the other mode? (TLS vs SSL)

The host of the FTP site (they use a product Citrix Sharefile) requires Implicit SSL/TLS (Port 990), so that's all I used in setting up the FTP connection - which, as I noted in the log file, shows the connection actually happening except for the 503 error at the end.

Just tried Port 22 and it failed outright per the log.
Just tried TLS (Port 21) and got this error: 504 Security mechanism 'TLS' not implemented.

I would try the other one since the site seems to want the authentication done in a different way to what's being done.

Did with no success (see edited previous post). Port 990 had best result per log other than the 503 error.

As a developer, does this 503 error message have any kind of explanation?
503 Expected the PASS command, not 'PBSZ'.

Looking more closely at the FTP log, I can see where it accepts my login info but then kicks out this 503 error. The window keeps showing a "logging in" message with a moving gas guage with Abort underneath it. The log eventually shows a "Timeout on Command 1001" error and then retries the login again. This keeps repeating until I abort the process.

It means the server is expecting the PASS (password) command before anything else, although that seems odd since the log suggests the account is already logged in at that point.

What does the log look like when using another client?

I don't have another client. Is there a freebie out there I could try and then check to see what happens? Do you have one you'd recommend I try?

Try turning on the SSL Data Channel - Use Clear Data option for the site on the Special tab in the FTP address book.

Just tried FileZilla and it showed this info during the connection attempt:

Status: Connection established, initializing TLS...
Status: TLS connection established, waiting for welcome message...
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 503 Expected the PASS command, not 'PWD'.
Error: Failed to retrieve directory listing

Didn't resolve problem. I'm wondering if the "failed to retrieve directory listing" message thrown off by FileZilla tells me I need to see how the site is setup for my access. Maybe I need more details from the host site or they need to turn something else on (like create a subdirectory for my account?).

If it's not working in FileZilla with the same error message then there's either a problem at the server side or a setting that needs changing which they haven't told you about. It doesn't look like an Opus issue.

OK, I'll check in with them this week and come back and post if I find a resolution...

1 Like