Problem with FTP connection / directory listing


i've got a problem if i try to connect to a ftp server. but these problems are just with DO, same standard settings are fine with both filezilla and smartftp.
connecting to other ftp servers is just fine, it's just this one refusing to give me a file listing ...

first off my settings:
using XP SP2, kaspersky anti vir software but no firewall except the standard windows built-in (DO is added to the exception list).

i tried with active/passive mode and each with binary/ascii/auto modi but the error message is always the same:

220 xxxx FTP server (Compaq Tru64 UNIX Version 5.60) ready.
331 Password required for xxx.
230 User xxx logged in.
215 UNIX Type: L8 Version: Compaq Tru64 UNIX V5.1B (Rev. 2650)
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
200 Type set to I.
257 "/people1/xxx" is current directory.
250 CWD command successful.
257 "/people1/xxx" is current directory.
200 PORT command successful.
150 Opening BINARY mode data connection for /bin/ls (,5015).
451 Local resource failure: malloc: No such device or address.

at this point the lister just returns to the previous view.

ok, now where is the problem that only DO is refusing to connect to just this server? i've googled for some time now but i didn't find any solution.

thanks in advance for all answers :slight_smile:

This is a bug in the Compaq FTP server software. It affected SmartFTP as well but they added a workaround: ... t9166.html

From that thread it's difficult to know for sure exactly which workaround(s) were needed. Do you know of any publicly accessible FTP servers running the same software? Or are you able to send GPSoftware some login details so they can test against the server you're connecting to?

hmmmm ok, thats going to be a problem since this is a server hosted by my university and it contains some private data. i'm not sure if i can give out the login to anyone. well i guess there wont be any real problems since there are just reading permissions for this user but i cant say if the data on the server has to be kept private.

unfortunately i cant provide a similar server with the same version ...

i guess i've to use another program then ... but thanks for your fast reply!

There's no public/anonymous area on the server then?

I tried finding a server running the same software but failed. I don't know if there's a good way to search for such things. :frowning:

i'm sorry ... no public access on this server :wink:. could try to reach an admin so he can fix the bug ^^

A friend who is better with Google than I am found a public server which seems to be running the same software:


I don't get any problems looking around that site, though. Maybe they have a fixed version of the server, or the problem only occurs in certain situations (e.g. a linked file in the folder, though I think I found a few of those). It could also be particular settings in Opus.

Could you try connecting to the site above with your Opus configuration and confirm that you don't see any problems reading a few directories?

no problem connecting and getting a file list ...

how very depressing :frowning:

Interesting issue. Even thought it's a server issue, if you can talk to me directly and give me access to the server login then I can run a debug session and see what's happening.