Problems moving Web Pages


I am a new user of OPUS and in my day to day work, need to file a lot of Web Pages which I collate for Classes I teach at Uni.

I am used to Windows Explorer where the HTML File and it's associated Folder are kept together when moving files from one location to another. OPUS doesn't appear to associate a Web Page with its Folder and so I often end up losing files in the process as only half the required material is moved. I haven't yet discovered a way of solving this problem. Any ideas?

I intend to recommend this program to my class members who are all retired and find the normal Windows Explorer interface a little difficult to use when working with files & folders. I am hopeful that OPUS will make their task a lot easier.

I am pleased with all the Tutorial material available. Please keep up the good work.


Hello Hotchips,

One solution to this problem is to create a Folder Format for the specific folder(s) that you need to associate a Web Page with its Folder.

A Folder Format can be added in Preferences -> Folders -> Folder Formats .
Once the folder one wishes to add a Folder Format to has been specified, a configuration dialog appears.

Check the View checkbox and choose details from the pull down list.
Check the Sorting checkbox.
Choose 'Sort by Filename' from the Sort By pull down list.
Choose 'Mix Files and Folders Together' from the Mixing pull down list.

That's it !
Now when you view that folder in Directory Opus, the Web Pages and their associated folders should be together.

:opusicon: porcupine

I bet you could also make a button which automatically selects the *_files folder for each .htm file that is already selected, and then does the copy.

It'd be a bit of effort to get it working and I've got pages and pages of forum posts to catch up on. :slight_smile: If you want it shout and I'll have a go.

Alternatively, you could save the web pages into a single MHT file (at least when using IE). Much neater that way, unless you need to edit/extract components from the page.

Yes, but the DOpus pattern matching syntax requires a ' character to escape ( , ) , [ , ] , # , ~ , and ' . Do you know how to turn off DOpus pattern matching ?

This was discussed recently in a very similar thread here .

:opusicon: porcupine