GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Problems with Dopus on usb-stick


#8

LockTabNavSub.osp (2.8 KB)


#9

I suspect if you add some DOpus.Output ... debug logging into your scripts you might find one or both are being called over and over again, which is causing the toolbar flickering and other problems.

When you tried disabling the scripts, did you move both of them out of the script folder to somewhere else, then fully exiting Opus (via File / Exit Directory Opus) and restart it? If not, please try that to see if both problems are triggered by the script(s).


#10

Yes, that I did.
But as soon as I close the log window the toolbar is flickrering. But not the icons are flickering. Only the dots which can change the size or the position of the toolbar. I have make a screenshot and mark yellow which part is flickering.

Flickering

Without my script I can change the folders. But it is a little bit more slower when the log window is closed.

The script log window is empty


#11

That sounds like something keeps locking and unlocking the toolbar, or toggling you in and out of Customize mode.

You may have something on your computer that is broadcasting window messages in the private/app range to other windows. Try closing other programs and background tools to see if it stops happening.


#12

I have stop all programs and background tools. Still flickering.
I also try dopus from usb stick on my home computer. The installed version works fine on my home computer. But dopus on usb stick also flickering on my home computer


#13

I just notice when the file display toolbar has the focus the whole file display toolbar is flickering.


#14

If you exit Opus completely and then re-launch it as elevated (right-click - or shift+right-click - on the Opus icon and choose "Run as administrator") does the flickering still happen?

(You'll know it's running elevated because the title bar will show ADMINISTRATOR in all caps).


#15

Also running as administrator it is flickering


#16

If you right-click the empty space on a toolbar, is Lock the Toolbars on or off?

If you toggle it, does it stay in that state, or return to how it was, or alternate between the two states each time you check the menu?


#17

The toolbar is not lock. If I toggle the state the toolbar get locked. But still flickering. Als as admin run.


#18

The same dots are flickering as shown in the screensbot above when the toolbar is locked?

Could we see a screenshot of the whole window when the dots are visible? That might show something.


#19

I have make a short movie. Hope this helps.Flickering.zip (3.2 MB)
You can see when the log window is close it is flickering. Than I open the log window. The flckering stop. When I close the log window the flickering start again.


#20

What is the tool that has added all the buttons to the window border at the top right?

Could you try uninstalling that and rebooting to see if the problem is gone then? It might not be involved, but tools which mess with window borders have often turned out to cause strange problems.


#21

This tool I have only on my home computer were I normaly use the installed version of dopus. And with the installed version I have not this problem. At work i use the usb version of dopus and this tool I not have on my work computer. Anyway I disable all tools on my work computer and still have this problem.


#22

Are the graphics drivers up to date?

Please try turning off Preferences / Display / Transition Animations / Enable transition animations in case that helps.


#23

The graphics driver are up to date.
Turninig off the animation not help.


#24

Have you tried exporting to the USB stick with the "use as a dongle" option turned on, and then copying the folder to a HDD and running it from there (with the USB stick still plugged in)?

That would rule out something to do with the USB hardware causing a difference.

The only other difference would be the configuration on the USB stick vs the one on your HDD, if you aren't writing the config out when doing the export.


#25

I only use the usb-stick as dongle.


#26

Try exporting from the working HDD install and overwriting the USB config with the HDD install's config.

If that still has different results then I'm out of ideas, and I think something on the machine is interfering in some way, broadcasting spurious window messages or making the window keep repainting parts of itself.


#27

I have install Dopus on a new usb stick not as dongle. And use the configuration of my home computer. Now it works fine.

Next I will configurate step by step to my old configuration. I hope I will find then the reason which configuration make the trouble. Only I wonder why this problem start with Dopus 12.8 because I have not change the configuration for some weeks.

Thanks for help