Problems with formatting in Windows 10

I think the problem maybe is a Windows 10 problem as my Laptop with Windows 7 is okay.

Here is what i want to see (this is windows 7)
Windows 7 - 1

This is what i have on Windows 10
Windows 10 - 1

I did right click in the window and chose Group by type which gave me a little hope. But it kept the format when I went in to C:

Hopefully somebody can help

Thank you very much

After grouping This PC by type, go to Folder > Folder Options, then click Save > Save format for a folder, and make sure Save for all sub-folders is off.

You'll probably also want to turn on the option above it (Replace this format's folder in any layouts and saved folder tabs), but that's usually less important.

Alternatively, you can edit the same format via Preferences / Folders / Folder Formats and then System Folders / This PC and set the grouping option there.

After saving changes, it's usually best to close any open windows and test with completely new ones, to avoid any holdovers from ad-hoc changes. (Ad-hoc changes will be kept when you change folders in the same window, unless the folder you change to triggers a different format.)

i have tried both your methods and restarted Directory Opus

but still a problem
Windows 10 - 1

Hover the mouse pointer over the format lock on the status bar (don't click, just hover).

What does the message that appears say?

there is no format lock on the left hand side displaying This PC

Have you tried to delete the file: "C:\Users\ethereal\AppData\Roaming\GPSoftware\Directory Opus\Formats\" and then restart Directory Opus again? (Backup first!?)

My mistake; I forgot that folder has a custom status bar.

If you go to This PC and then select Folder > Folder Formats > Reset to Folder's Format, do you get the correct grouping then? If so, which method are you using to open the window? It may be overriding the normal format.

thanks leo. that one worked

Presumably the issue comes back the next time you open a new window. If so, which method are you using to open the window? Are you opening the default lister, or a layout?

They both have options for whether or not they should override the normal folder formats, but the exact place to look depends on how the window is opened / what the window is opening.

i use both default and layouts so please explain both methods for me.

thank you

For the default lister, make sure Preferences / Launching Opus / Default Lister / Ignore folder format of Default Lister is on.

For each layout, make sure Preferences / Layouts and Styles / Layouts / Ignore folder formats saved within this layout is on. (You also get asked about that when saving a layout. It'll use the layout's current setting or the last used setting by default, but you get a chance to change it each time.)

For styles and folder tab groups, there are similar options inside each one.

i got this working with all of my saved layouts but this is the default lister

Windows 10 - 1