GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Ps/eps viewer again


#1

I have seen this subject in here before, and it seems there is no eps viewer plugin available for Opus at this point (well, not for 64-bit anyway). Now, admittedly I really don't know much about how these various plugins work, but it seems to me that, since Windows Explorer can show me the eps preview just fine, Opus should be able to do that, too. My guess is that Explorer somehow uses a plugin that my Ghostscript installation provides. Now if somebody could explain to me how I could teach Opus to use this, too, then we would be all set. Or am I being naive here?


#2

If you can view EPS files in Explorer's preview pane (not in a separate window or as thumbnails, but in the actual preview pane that opens on the side of the normal Explorer windows) then that should also work in Opus.

If it only works in Explorer, please open an Opus window and select Settings -> Preferences / Viewer / Viewer Plugins, then select ActiveX + Preview + Office + Web and click Configure. In the top part of the list there should be a program or component that is assigned to the .EPS extension. What is it?

There is also an EPS plugin for Opus here: Adobe Illustrator, EPS, INDD and PSB thumbs/viewer

Also, the Universal Graphics Viewer Plugin will show the first page of EPS documents if Ghostscript is installed.


#3

Opus kind of shows the eps file in the previewer, but it shows it as text in hex mode. I guess if I knew where that's configured, I could remove or change that setting, but I can't find it. Any idea where it could be? My viewer config is stock Opus 10 at this point...


#4

I already said where. :slight_smile:


#5

Hmm, yeah, you did, but maybe I'm a bit slow in the uptake today...

Try as I might, I simply couldn't find .eps anywhere in those settings, so how/why does the previewer decide to show the eps as a binary file? My guess is that the fact that the previewer thinks it needs to show it as a binary file prevents it from using Ghostscript to show the proper preview instead. Am I right at least that far?

By the way, thanks very much for your prompt replies. Your help has been invaluable!

P.S.: As an aside, I wonder how the system for deciding what to use to show these previews works in general. For example, initially, when I tried to preview an MP3 file, it brought up Apple's Quicktime (I mean, seriously, Quicktime???). Where did it get that idea? So I checked the box to use WMP (ignored the warning message; any way to get rid of that?), and now my MP3s play through WMP, as they should. Contrary to what that warning message says, at least in Win7, WMP is often by far the best choice...


#6

Here's some more info: I tried adding .eps to the generic ActiveX handler in ActiveX + Preview + Office + Web, and that did have some effect. At first I thought nothing had happened, I just got a blank pane, but then I saw that behind the Opus Window, one of my Adobe Illustrator toolbox windows had popped up. Apparently, the previewer somehow had invoked Illustrator, which, in principle, could have been a viable choice, but it seems Illustrator really doesn't work well (or at all?) in the previewer. In any case, loading Illustrator for a preview is dead slow, and really a terrible choice.

The question is, how does Explorer know to use Ghostscript, and how can I teach the Opus Previewer to do the same?

Oh, maybe I should add that all of this is on 64-bit Windows 7. The 64-bit part may make a difference here.


#7

If MP3 is assigned to Generic ActiveX then Opus will try to show the file using whatever is the registered ActiveX handler for the .mp3 filetype.

On your system that's Quicktime, probably because Quicktime was the last tool you installed that registered itself. Whichever tool was last wins. If you re-assign the MP3 filetypes to Windows Media Player (as per the FAQ on this issue) then it will take over the ActiveX handling of MP3 files (and you won't have to use the WMP preview handler instead, which is pretty rubbish, as the warning says).

if Opus is displaying EPS files as hex data then it just means Opus doesn't know any better way to show them.

Explorer cannot view EPS files by default, so you must have installed something to enable it to do so. If you can work out what that was I'll install it as well and see if I can work out why it doesn't work in Opus.

As far as I know, Ghostscript on its own doesn't install a preview handler for Explorer, but maybe I'm wrong/out-of-date and it does now. Does anyone reading know? (I've not had much luck with Ghostscript in the past, but it's been several years since I last had reason to try using it.)


#8

O.k., I solved the MP3 issue but, boy, that was a bit of an exercise. Those straightforward instructions that are in the FAQ didn't work, mostly because of the way this stinking pile of crud called QuickTime had messed up the MIME associations. :unamused: In case anybody else has this problem, you need to go into the registry and manually straighten out the CLSIDs for audio/mpeg and audi/x-mp3, both of which Apple's piece of garbage sets to be run through its own player, and doesn't provide a way to reset...

So now indeed the Opus previewer plays MP3s through WMP. However, when I had checked WMP handling in the ActiveX handler plugin, I had a nice WMP window with album art, whereas now, with the WMP handling unchecked, I just get a black background while the MP3 plays. So, to me it looks like checking WMP handling in the options of the plugin gives me a better result. But both the plugin and you claim that the WMP preview handler is not very good. Why? To me it seems to work quite well.

Anyway, for the main issue of the eps preview, yes, it seems that natively the Opus previewer doesn't know what to do with EPS. I may well have something installed to allow Explorer to do this, but I'm not sure what it could be. Does anybody know how I could find out (possibly from looking at the registry) how Explorer gets the eps preview? I do have MysticThumbs installed, but that's only generating thumbnails, I think. Works great by the way. For anybody who is looking for a Thumbnail generator on 64-bit machines for EPS, PDF, and just abouit anything else you could ever think of, you should look into MysticThumbs. It's not free, but it works well.


#9

My main issue with the WMP Preview Handler is you have to click Play to make it play the file, while the WMP ActiveX starts playing automatically. That's about it, though, so if you prefer the preview handler there's no reason not to use it instead.

When viewing EPS files, can you scroll through the different pages or does it just show you the same as the thumbnails but larger? Explorer falls back on showing huge thumbnails when there isn't an actual viewer, which Opus doesn't currently do. It should be pretty easy to make Opus does the same if it's useful.


#10

Ahah, I think that's what's happening. Yes, I only get to see the first page in the preview (which is fine for my purposes, since the eps files I have are all single-page graphics files). So if you could make Opus act the same way, that would be great!

By the way, on the MP3 issue, I am sure I'm not the only one with this issue (as a web search revealed...). Maybe you could add the additional steps I outlined above to your FAQ. To be specific, people need to go to HKEY_CLASSES_ROOT\MIME\Database\Content Type\audio/mpeg and to HKEY_CLASSES_ROOT\MIME\Database\Content Type\audio/x-mp3, and reset the value of the key CLSID to {cd3afa76-b84f-48f0-9393-7edc34128127}.