GP SoftwareTwitter
Opus FAQsManualCommandsObjects

PSA: Check your muted topics


If you went to Unread, then used the Dismiss button at the top-right, expecting to mark all the old topics as read, it turns out it also mutes those topics (update: But only if you click the checkbox inside the confirmation dialog, which makes it mute in addition to marking as read).

I did this myself, and also suggested doing it in another thread without realising.

If you did the same, or followed my bad advice, you can undo it as follows:

  • Going to your list of muted topics
  • Select everything via the = button top-left of the list
    (Note that it only selects as much as you have srolled into view, so you either need to scroll a lot, or refresh later and repeat the steps.)
  • Click the spanner on the top-right
  • Click Change Notification Level and set it to Normal or Watching or whichever you want.
  • Do a full F5 refresh afterwards, since the page starts showing you latest topics, not muted topics, after making a change.

F5 Refresh the list afterwards to see if anything is still muted, and repeat until fixed.


Thanks to help from the Discourse forum I’ve learned that the Unread > Dismiss buttom is fine, and will just mark everything as read, as long as you don’t touch the checkbox inside it, which also mutes everything.

I think the first time I used it I must’ve assumed the checkbox was for confirmation, not to make it do even more.


It turns out Discourse may well be doing something unexpected here, but they are still looking into it.

So I recommend checking if you have lots of muted threads, as per above, just in case the same happened to you.

Here’s the discussion about the issue on the Discourse forum, for anyone interested: