Question regarding context menu entries

I tried using winaero tweaker to set new file context menu entries for vbs, cmd, bat reg and ps1. They all show up in explorer as well as dopus except for the new ps1 file that does not show up in dopus for some reason.

I would like to know if there is a fix for that.

For now I got it sorted with this powershell command and a new button I created like so:

powershell -noexit -executionpolicy bypass -command cd {sourcepath}; "New-Item -ItemType file -Name 'New PS Script.ps1'"

Is it possible to have that in the 'new' submenu? Thanks for your inputs.

I have another related issue as well that only affects .ac3 files,

when I use the open with context menu on them i get 2 empty entries with a smiley.


These do not show up in file explorer. I would like to know if there is a way to clean those or maybe I got something twisted I don't know... but most probably not, I never messed with that file format in the registry or anything similar.

I understand that I could hide file explorer items and create my own context menu but that is the only thing I want to change so it would be more time-consuming for me to recreate all those buttons rather than just figure out that one issue.

Thanks again for any help.

There must be something different about the .ps1 filetype in the registry compared to the others.

If you go to Settings > File Types in Opus, then at the top File > Diagnostic, you can make snapshots of the relevant registry data for two types to compare them. Post them here and we can take a look.

You can also make Opus buttons, hotkeys or menu items to create specific file types: How to Create New/Empty Files

A diagnostic of the .ac3 file type might reveal what's wrong there.

Here are the diagnostics if you don't mind taking a look. (65.0 KB) (62.9 KB)

I use sublime text to open ps1 by default and then I use the notepad replacer tool to have it as default text editor in windows so there might be some interference there? As for ac3 I don't know.

Thanks again for your help, the link seems cool as well I will try it.

Edit: FileType NEW=.ps1 seems not to be working either... but it does with .txt

I think I found the culprit in the diagnostic for ac3? Most probably this but I am no expert.

64 HKCU\Software\Classes.ac3\OpenWithProgids: "AppX6eg8h5sxqq90pv53845wmnbewywdqq5h" is REG_NONE
64 HKCU\Software\Classes.ac3\OpenWithProgids: "AppXqj98qxeaynz6dv4459ayz6bnqxbyaqcs" is REG_NONE

Edit: That was it. I went in regedit, deleted those 2 leftovers and my issue was solved for .ac3, for some reason win explorer does not display non-assigned prog ids while dopus still does, that's why I could only see it there.

As for .ps1 I am still looking into it let me know if you find anything please and thanks for the first one!

1 Like

Okay so it seems this finally worked for me, that command was at the bottom of the topic so I kinda missed it.

FileType NEW=.txt NEWNAME="New.ps1"

It auto increments the number as well.

The only thing I would have liked is to put it in the 'new' context menu but that's just a pet peeve at this point. One more time, thanks!

1 Like

We might be able to filter them out. I'm surprised it hasn't come up before, in fact, as I don't think things normally remove those entries when they get uninstalled.

(Edit: It may be something special that we're doing for the AppX... obfuscated prog IDs which Microsoft Store apps use, since they have to be looked up in a special, convoluted way. That, and those apps being fairly rare outside built-in ones that can't be uninstalled, is probably why it hasn't been noticed before.)

Glad it's all working now.

When I get a moment, I'll try have a look in more detail at why the New .ps1 item didn't work automatically as it looks like it should. But file types in Windows are a lot more complex than they should be, with so many overrides in different places.

My guess was correct, and we've fixed that for the next update.

The issue with the .ps1 new item not appearing has also been fixed. That was due to the item not having a description in the registry.

1 Like

perfect, thank you!

1 Like