Reading Font Directories

Dopus Vn

I finally found 4 related fonts (ttf) which caused every Lister to abort (fade away without saying anything). This was in a directory of ~3k fonts and I could see and access the other fonts until (?Dopus) read the subject file and aborted.

During the Open time there is 100% cpu usage which could last 15 seconds or so. As I cut the number of files down the time got shorter and shorter until I didn't see the Lister at all.

In Font Creator (font editor) I could see nothing very peculiar about them but I removed their hinting and that solved the problem with the Listers.

Is there something that Dopus is/shouldn't be doing on these fonts? They are accepted by all my other font programs. (324 KB)

FYI - I have another error "working" -- in a group of 250 fonts, so it's not just the previous 4 which have a problem. I'm not looking for them, they just show up. They're hard to isolate so I don't know how many or anything.

I've been working large numbers of fonts for years with Dopus and has never happened before.

Thanks for the report, I think I've worked out what the problem is.
We'll try to put out an update in the next day or two.

In the mean time if you make sure you have the Description and Font name columns turned off it should prevent the crash.

You're very fast -- I love it!!

I don't have those two columns turned on. On all my fonts the file name is font name so would be redundant.

Thank you again for the quick response. Dick Pape

Hurray. Vn is working just fine on all my problem fonts. Whatever "adjustment" you made addressed it all. Thank you for looking into this right away and for issuing an immediate fix.

(Sorry I already bought Vn 9 so can't send anymore money!)

Dick Pape

Buying version 9 doesn't stop anyone from sending more money.

I'm sure GPSoftware will provide you with bank account details for direct deposit. :smiley: