GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Reassign a key combination : Win+Y


#1

I have a script not from DO assigned to the key combination Win+Y, but when I try in DO the result is the Find option.
How can I configure this to free this combination and assign to my script ?
Best Regards

I have tried the customize option and have reassigned some other combinations like control+shift+w, but I don’t see the combination Windows+Y


#2

Do you mean this happens?:

200dpi_wc11075_dopus

That indicates that Windows is telling Opus that the Y key was pushed on its own, and the Windows key is being ignored with that key sequence, for some reason.

Win+Y seems to be a Windows hotkey to do with Mixed Reality support, so maybe this is what the OS does if no related hardware is installed.

Exactly the same thing happens in every other program I have tried with. For example, open Notepad and push Win+Y and it just types a ‘y’ character as if you had just pushed Y.

I don’t think this is related to Opus.


#3

Yes , It is.
But don’t happen with Windows explorer.

What’s next ?


#4

What doesn’t happen with Explorer?


#5

John , my script is about to open a menú and select a name for create an empty txt file in the opened folder.
I use the hotkey win+y for this purpose.
I don’t expect nothing to happen when the cursor is in notepad. But I hope DO can emulate better than explorer.


#6

Explorer doesn’t let you assign hotkeys at all.


#7

Jon I am not telling you that.
The combination win+y Works under Windows explorer and not in DO.

under Windows 8.1
I need to show the full path in the window title to work correctly.
I do the same in DO, but don’t Work.

Best Regards

p.D. I will try to assign other hotkeys meanwhile.


#8

In what way does Win+Y work under Windows Explorer? What does it do?


#9

Well that is a good question.
So I will put the ahk script here to analyze if you want.
The script is for creating empty txt files in a folder selecting from a menú. When the win+y combination is pressed a window is open showing a list of txt file names to be selected. you can select one or several and intro creating all the txt files in the open folder.
At the present momento Works with Windows explorer, but don’t do under DO.

Best Regards


#10
#SingleInstance Force
 
    #ifWinActive ahk_class CabinetWClass
    {
      #y::
      Gui, Destroy
      WinGet, WinID, ID, A
      Gui, +LastFound
      HWND := WinExist()
      ControlGetText, DesPath, ToolbarWindow323, ahk_id %WinID%
      StringMid,DesPath,DesPath,Instr(DesPath,": ") + 2
      Gui, Add, ListView, r10 NoSort vChosenName h300 w400, File Name (Path: %DesPath%)
         For A,B in {1:"Instrucciones.txt",2:"Instalar en mv.txt", 3:"Es mal portable. Instalar como no portable.txt", 4:"Instalado como portable.txt", 5:"Instalar cuando se pueda.txt", 6:"ReciboLLamadaAlas.proponer fecha hora.txt", 7:"Ver pantallazos.proponer fecha hora.txt", 8:"Ver grabaciones de la fecha.proponer fecha sistema.txt", 9:"password   pegado del portapapeles.txt", 10:"Avira detecta virus. en parte a especificar.txt", 11:"File11.txt", 12:"Es un juego.txt", 13:"Es para entorno MAC Apple.txt", 14:"Tambien tienen versiones de pago.txt", 15:"No es buen portable.Instalado como portable.txt",16:"No funcione en xp. es para w7 o sup.txt", 17:"Nuevo Notepad++ Document.txt",18:"Script AutoIt.au3",19:"Script Autohotkey.ahk", 20:"es un trial de prueba.txt", 21:"ae.fecha.txt",22:"File22.txt", 23:"File23.txt", 24:"File24.txt",25:"File25.txt",26:"File26.txt"}
        LV_Add("",B)
        Gui, Add, Button, gChoose, Submit
      Gui, Show, h340 w420, Choose File Name
      Return
    }
 
    Choose:
    ControlGet, List, List, Selected, SysListView321, ahk_id %HWND%
    Gui, Destroy
    Loop, Parse, List, `n
    {
       If !FileExist(DesPath "\" A_LoopField)
          FileAppend,, %DesPath%\%A_LoopField%
    }
    Return

#11

Sorry. I don’t need to show the full path in the title bar for this script.
That happens with other script unde Windows explorer. At the present moment I am using in both environments (DO and WE) . Sometimes fails in DO. I am debugging.


#12

So you’re saying you’ve actually assigned the Win+Y key through AHK?


#13

You are a clever man.
I did.


#14

Then that’s something you’d have to ask the makers of AutoHotkey about.


#15

balls outside magistral game.


#16

Make sure you aren’t running the whole dopus.exe process UAC-elevated as Administrator, as that could block hotkeys installed by other processes, and would be a difference between the Opus and Explorer processes.


#17

Thanks Leo.
I am the administrador and I have totally disabled the UAC service. I don’t use because interfere with some features of my CRM.
Best Regards


#18

That should be OK then. If UAC is completely disabled then it won’t be a factor.


#19

I will try with another key combination and comment.
Best Regards


#20

I have try control+shift+y
Didn’t work under DO.
Goes well under explorer.
What’s next ?