Registered user, but files and directories truncated (old 8.3 style)

Using registered Opus version 10 and Win 10 (2004). Some of the files and folders (but weirdly not all) started appearing in the old 8.3 style; other files/folders all in caps.

I see others have the problem if using a hacked version. Mine is registered (since 2011).

I tracked the problem to Norton's firewall inexplicably blocking Opus (Norton also blocked two other apps in its frenzy).

Unblocking Opus temporarily fixes the filename issue, but on Opus reload or system reboot, problem re-occurs.


That sounds like unblocking the process in Norton is only temporary, and the setting is reset next time the process restarts. There should be a way to make it permanent, if that's what seemed to be causing the problem.

Opus not having internet access should not do that (it will work fine with no internet connection at all, for example), but I don't know exactly what Norton is doing there. You would have to ask Norton about that.

It completely blocked Opus (remember Eudora -- it blocked that, too, and some other older apps).

I changed Norton's settings to Allow all the apps and rebooted the system. Eudora and the other apps are ok, but Opus still presents this odd behavior.

I poked around the forum and it's happened before.

Is the CAPS only display something you've hear about before? And with that in mind, you're saying no Internet access will NOT cause 8.3 display?

Lack of internet access should not cause 8.3 names. But I have no real idea about how Norton is modifying the program or the OS APIs, so I can't say what that might be doing.

It must be something Norton is doing, if unblocking the process fixes things temporarily. (I'm assuming the problem stays away from that point until you restart, and that you've tested like that for several hours, not just a few minutes.)

Have you tried uninstalling Norton to check that? Or asking Norton for advice on ways they may still be interfering despite whichever setting you changed in Norton's configuration?

Ask Norton? LOL! The megamonolith is nothing like Opus where I can actually talk to a developer.
I'll do an Opus backup, upgrade to the new version (it's time), reinstall, and see what happens. If you don't hear from you, all is well. Standby...

1 Like

I'm still intrigued by why Norton and Opus can't coexist.

I closed Opus and disabled Norton's firewall. Launched Opus with firewall disabled, and within minutes, files are in CAPS, 8.3 files are displayed, and weirder yet, files in a mapped SSD card (on a router) displays random file names.

I tried again, this time disabled Norton's A/V module and firewall. 12 minutes later, same problem.

Is this still with Opus 10 or are you trying with Opus 12 now?

Still on 10. Wanted to get that resolved before updating.

I unsinstalled and reinstalled Dopus 10, restored settings from the backup, and everything's been fine ever since.

I experimented with Norton by completely blocking Dopus from accessing the internet. No problems, except, as expected, no alert to update Dopus.

My guess is that there was corruption within Dopus which was removed when I reinstalled it.