Removing a Flash Drive

I have an odd-ball problem with one of my flash drives. When I click Safety Remove Hardware on the system tray and select the flash drive, the following warning appears " The device 'Generic volume cannot be stopped because a program is still using it". This warning appears even though I have closed all app's.

I'm wondering if DOpus is involved. When I plug in this flash drive, DOpus automatically starts, and the icon remains in the system tray. However, even if I close DOpus by right clicking on the system tray icon, I still cannot remove the drive. I've checked Preferences, but since there are so many "preferences", I may have missed the appropriate choice.

I'm using DOpus 8 and XP Pro, and the flash drive contains many Word documents.


Easy way to find out is to exit Opus and then see if you can dismount the drive.

Closing Opus doesn't resolve the problem. I tried the problem flash drive on another computer also running XP but without Opus installed, and had no problems unmounting it. I reformatted it using the Control Panel Administrative Tools>Computer Management>Storage>Disk Management - on the non-Opus computer.

I put it back in this computer, Opus didn't start automatically, and I was able to unmount. I restarted the computer and tried again. This time Opus started and I was unable to unmount. I think there is some sort of quirk in this computer involving Opus. How can I change Opus preferences so Opus is not the default file manager?


If Opus is completely exited then it can't be what's locking the drive. (Or, at least, it can't be the only thing locking the drive. It's always possible that both Opus and some other thing is holding a lock.)

Did you fully exit Opus or just close all the windows?

You can sometimes use Process Explorer to see which program(s) is/are holding locks on a device. Open the program and then push Ctrl-F and type the drive into the box, e.g. G:\ and then push Search. I think this will only find locks on files, not folders or the drive itself, though, so it may or may not reveal what's preventing the drive from being ejected.

At times, when I've had this problem, I've found the freeware program Unlocker (at ) to be useful.