Rename multi-command button fails

Win 10 Pro 12.25.1
I have been using this button

Clipboard Paste
Select "Cilpboard Image.jpg"
Rename CASE=allwords
Rename TO="{parent}.{ext}" FILEINFO
Rename REGEXP "(\D+) (\d+) (\d+)" "\1 \2 \3p"
Rename TYPE=files REGEXP pattern " 720p*" TO "-F" FINDREP
Rename TYPE=files REGEXP pattern " 1080p*" TO "-F" FINDREP
Rename TYPE=files REGEXP pattern "(.+)(-F)\s*(.+)(.*\..*)" TO "\1-F\4"

For many years to copy an image into clipboard then paste in folder and rename to folder removing everything after for example Fred S1 2021 720p works in 12.25 and fails in 12.25.1

When it gets to Rename REGEXP "(\D+) (\d+) (\d+)" "\1 \2 \3p" it opens the Rename dialog

Cilpboard Image.jpg is not spelled correctly. :slight_smile: (It's probably working anyway because the command before that selects the file it creates.)

Rename REGEXP "(\D+) (\d+) (\d+)" "\1 \2 \3p" is not specifying which argument the "\1 \2 \3p" part is for. You're missing a TO there, I think. Compare it to your other lines.

(As an aside, FILEINFO isn't needed anymore, but is also harmless.)

Never noticed I'd spelled clipboard wrong
Have reinstalled 12.25.1 added the To and it works.
What had been changed between 12.25 and 12.25.1 that would have caused it to stop working.
Going to have to have a good look through my buttons as I will have a lot that do not have the TO
Super quick response

If it worked in 12.25 I think it was just luck, as the command wasn't really valid.

There was a minor change to the way argument parsing worked in 12.25.1 which might account for the difference. If it did, it worked before due to a bug, and should never have worked without the TO. :slight_smile: