Rename multiple files in an folder

lease see attached file
there are a x4 files shown, blue devices, parts of a mechanical clock.
on the menu bar across the top RH corner is shown RENAME.

i would assume if i highlight the x4 files and click rename then i can rename these multiple files in a sequential way, ie file01, file 02 etc, which is what i want to do

what happens though is only the first files is so renamed whilst ALL the others are left with their original name.

if i use that horrible program WINDOWS EXPLORES i can do EXACTLY what i want with NO issue

i might add im kinda bamboozled as to why this is not working, apart from the possibility im doing the operation incorrectly, but the fact internet ex works just fine tells me the issue is not me.

so again this is one of the many issues i finds with DO, an very difficult program or come to grips with at times. i have also check the help files and well thats a waste of time as what is said there amounts to a whole lot of convoluted worm language, ie double talk on another dimension.

oh and as im about to send this i cant see an option to attach an screen image of the task im attempting......of which im sure that was once in past postings, an option stuff it

huh i tried upload in a vain attempt to attach said pic. and it worked. well there you go UPLOAD. how about creating even more the ambiguity.
this is pretty ambiguous, maybe ATTACH would be a better more logical instruction

and yes im really frustrated with this stuff as i have spent 1 hour trying to fathom out rename. gggggggrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr

Above the post editor is an Editing & Formatting Tips link:


If you click that, the first thing it shows is:

i've found the same thing with bulk renaming. doesn't behave as i would expect it to. not something i do very often so haven't looked into it more deeply.

thanks for your reply. taken onboard your suggestions BUTTTTT most, if not all other programs i have had a need to sent images as attachments use an control icon that looks like an PAPERCLIP, and if you cursor over it a window pops up saying ATTACH. but DO has to use something different it seems, ie UPLOAD. in this case upload wound seem to mean, upload this request for help. again another DO ambiguity.
but thanks anyways

If you want to do it the File Explorer way:

  • Make sure Preferences / File Operations / Inline Rename / Rename all selected files at once is turned on.

  • Select the files and begin inline rename, the same as you would in File Explorer.

    • In other words, either push F2 or right-click one of the selected files and choose Rename from the context menu.
  • Type the new name and all the files will be renamed using that name, like in Explorer.

Alternatively, if you want to do it via Opus's advanced Rename dialog, which gives you more control (but also more user interface to deal with):

  • Select the files and click Rename on the toolbar.

  • Turn on the Sequential numbering from checkbox.

  • Change the New Name field as appropriate.

The preview at the bottom of the Rename dialog will show you what will happen and you can adjust the settings and patterns to get what you need.

We didn't write the forum software, and this forum software is now pretty standard across the web, so it's best to get used to it. There is an upload button on the toolbar above the post editor as well, although it isn't using the icon you expect. So there are three easy ways to add images to posts, and the instructions are there if you can't discover them. If you want to complain, talk to the people who make Discourse, which is the forum software we use.


cheers @Leo

again thanks for your reply, but as i did say before most programs use ATTACH when there is a need to attach something like a picture, etc. why not stick to the ways of the common man. anyways , thanks

You are asking the wrong people. We didn't choose the icon the forum software uses.

1 Like

thanks for your reply.

i really dont care what tools i have to use as long as the tool chosen works.
in the immediate quote above i can see where things went/ go array.
you say "select, then turn on, then change"

i have found when you open the RENAME tool the FIRST thing you must do (after select) is click SEQUENTIAL, as if you dont do this then the rename operation fails, so maybe there should be an instruction like, CLICK SEQUENTIAL FIRST. anyway another DO gotcha solved but a LOT of wasted time to boot.

checked this and "rename..." was ticked. the issue was the order in which SEQUENTIOL, as described moment back is ticked. so anyway :upside_down_face: :upside_down_face: :no_mouth:

You can tick it whenever you want, right up until you click OK.