Renaming files don't rename files with parentheses

I'm running this button

Rename PATTERN="*" TO "*" TYPE=files CASE=extlower AUTORENAME
Rename PATTERN="*.jpeg" TO "*.jpg" TYPE=files CASE=extlower AUTORENAME

over all selected files - but all files with round parentheses are not renamed:

"IMG_2160 (Bearbeitet).PNG" is unchanged but "IMG_2368.png" worked.

Any idea (DO 12.16)?

It seems to work fine here:

Interesting ... I just turned on the computer, would try it again - but not required - the file in the folder was renamed when I did it above - only those file names were not refreshed on the screen when I've reported the bug. Never seen this before ...

I just selected 48 files pressed the button again - but it didn't "rename" all:


but - after pressing "Refresh current folder" - the renamed files where correct.

Finally it doesn't always refresh all files. Mysterious ...

Is this on a NAS?

No - simple external USB3 NTFS .. Lacie 4 TB.

I also renamed other 1000 files in other folders on it and it worked.

However - not important. Maybe hard to find - so don't investigate time. I will keep an eye on it with the next photo session. :wink:

PS: The only one thing I see on both examples - all (not refreshed) file names have a space inside - except the last one on screen shot - but 3 x "!".

Next time you do a rename on the drive, try opening the folder in Explorer at the same time, then do the rename in Opus. Does Explorer see all the changes without refreshing the folder, or is it similar to what you see in Opus?