Renaming files triggers keyboard shortcuts

I can't see anyone else who has this problem. When I try to rename a file and start typing the new name, it triggers DO's keyboard shortcuts, e.g. going back, up a level etc. Is anyone else having this issue? Is there a way I can stop it from happening?

:: Edit - I have found a temp fix by unchecking all the keyboard shortcut options in preferences.

Many thanks in advance


That's strange.

Do you mean inline rename (directly in the file display, and not via the Rename button/dialog)?

Which key(s) are you pushing when the Back operation is triggered?

Have you customised your hotkeys or are they the defaults?

Do the same keys trigger things in Opus windows if another program is active?

Hi Leo,

  1. It happens both when I use the rename button or when I rename by left clicking the file name once to activate renaming.
  2. I unchecked all the keyboard shortcuts in DO and that worked for about an hour, but it's doing it again.
  3. Example: I activated the rename (the file name highlights and the cursor activates within the filename). I pressed the letter 'c'. DO activated the 'find' function and a 'c' appeared in the find dialogue box. Another example: I activated the rename and pressed backspace. The filename cleared completely (expected as everything was highlighted) but when I typed the letter 'u' DO went up a level in the file heirachy.
  4. Regarding the other program active question, I'm not sure if it is that as the problem seems to be intermittent. Sometimes if I pause for a second before type the new name, it seems to work OK (sometimes not). I am using a programmable logitech keyboard and mouse both of which have some keybindings but they are not bound to individual letters but combinations (e.g. Ctrl A).
    Help! :slight_smile:

Thanks for coming back to me so quickly!


I've just made a video of it. I'll send you the link once It's synced in dropbox. It cuts off at the end, but as I tried to rename the file using DO's 'Rename' button (which did something different this time, usually it activates the filename with a cursor on it), but when I tried renaming I was told access was denied.

Video link here:

:: Edit:: sorry, I was getting permission denied to rename the folder because there was a file open in it. Just closed it and tried the DO rename button which brought up the wildcard rename menu and that worked fine!

In the view, it looks like what would happen if you pushed Alt + Left. Is the Alt key stuck or anything like that?

Definitely not the 'alt'. I did press the shift key. Tried it again (inline) and the letter I typed came up in the search box at the bottom of the pane. Then I tried it without pressing the shift (worked fine). Then I pressed the shift and tried again and it worked fine. I think that the reason why the letter is coming up in the search box is that DO goes out of edit mode before I type the letter, so it treats it as a normal search?

I'll try a fresh reinstall and will let you know what happens.

The fresh re-install has solved the problem! (at least for now). Anyway, I am happy, my computer is happy and the problem has gone!

Thanks so much for looking at the problem...I guess it was just 'one of those things'.!