Right click crash with Bitcasa cloud storage software

Using Directory Opus 64 bit Windows 7. I'm getting a right click crash, and it's caused by "Bitcasa" and online storage service, bitcasa.com/. The program installs a virtual drive and also a right click menu extension to send folders/files to it. I do not get a crash when using Windows Explorer. I tried following the instructions at Directory Opus FAQs > Crash, exit or high CPU when right-clicking certain files to get the CLSID for a work around, but DebugView didn't provide any. Sometimes the below message has displayed. I have not yet contacted Bitcasa support, since Explorer works fine. Thanks in advance for any help.

I have this same problem doing a right click on a normal drive, I do however have Bitcasa loaded, but not running.

Please try using ShellExView to find and disable any Bitcasa shell extensions, then reboot the machine and see if the problem remains. (You can re-enable them after the tests, of course.)

Let us know what you find, and if possible the type of shell extension which was causing the problem and its CLSID (ShellExView can tell you if you right-click the extension and open its properties). If it was the Bitcasa extension then it would make sense to report the crash to them as it is difficult/impossible for us to debug their code & find out where it is crashing, unless it is open source. (We may be able to blacklist their extension, however, depending on its type.)

They had three entries
Context Menu
Icon Overlay Handler
Icon Overlay Handler.

I disabled all three. Not sure if I need to reboot. I didn't and it failed again, this time right click on a network mapped drive. Yesterday same drive was ok.

I must have been sleeping, I hadn't rebooted. I have now. Appears to be clear and working.

I got the relevant item from the eventlog from before, for you.

Faulting application name: dopus.exe, version:, time stamp: 0x510a1c22
Faulting module name: ole32.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c92c
Exception code: 0xc0000005
Fault offset: 0x00000000001729ac
Faulting process id: 0x30c
Faulting application start time: 0x01ce1e14676361fc
Faulting application path: C:\Program Files\GPSoftware\Directory Opus\dopus.exe
Faulting module path: C:\Windows\system32\ole32.dll
Report Id: 5f64750d-8ab0-11e2-af22-001cc08f2f03

Thank you, I didn't think of using Nirsoft's ShellExView to disable the extension. By elimination, the culprit CLSID is {92224F8D-0235-4EBB-BEFB-91AC297C4AEE} - Bitcasa Infinite Storage Context Menu.

There are three Class IDs - Bitcasa Infinite Storage Context Menu Class ID {92224F8D-0235-4EBB-BEFB-91AC297C4AEE}, BitcasaIconOverlay Class Icon Overlay Handler Class ID {A6975448-A999-49BB-B3E4-7730CF6A82C0} and BitcasaProgressOverlay Class {6FB8D52A-0064-45B2-B687-F596FEAD09C2}. But {92224F8D-0235-4EBB-BEFB-91AC297C4AEE} is causing the problem for me anyways.

I have placed a support request with Bitcasa, but I doubt it will progress anywhere. I can live without the extensions if it doesn't.

Many thanks! It has caused a few people problems now, so we will add that CLSID to our list of shell extensions that Opus should avoid.

You're welcome and thanks for the fix in the beta.

I did hear back from Bitcasa support, but it wasn't promising. They said: "Directory Opus uses an explorer replacement which Bitcasa also uses. Unfortunately, I don't have a fix right now, but we'll look into it for a possible future release. Thank you.".

Then in a later followup: "This is a quick reminder that your support request has been pending for a few days. Since I haven't heard from you in a bit, I'm going to solve the ticket for now, but feel free to update your request at any time. Your additional comments will automatically reopen the ticket!".

FWIW, while Opus and above will block the Bitcasa shell extension by default (so it isn't loaded), if they want to remove the block for testing they can do so via Preferences / Miscellaneous / Advanced: allow_context_menus.

Unfortunately, I'm still getting the right click crash even with beta I even tried adding the 3 CLSIDs ShellExView had for Bitcasa to Pref > Misc > Adv > ignore_context_menus. I thought I could use Bitcasa without the context menu, but it seems to be the only way to copy or mirror a folder to Bitcasa.

So the crash goes away if you block BitCasa's extensions system-wide via ShellExView, but not if you only block them via Opus's ignore_context_menus?

If so, BitCasa's extension(s) may be crashing in places that Opus cannot block, without the extension(s) being blocked system-wide. There are a few places where Opus does things like ask Windows to build a context menu (e.g. when your right-click on the root of a drive, rather than a file or folder below that drive) or when Opus asks Windows to which icon and icon-overlay it should display for something, and those will always call any shell extensions which are not blocked system-wide (since it's Windows making the choice of which extensions to use, not Opus itself).

If that's the case, you'll need to block BitCasa's extension using ShellExView, and I'd suggest complaining loudly to BitCasa for them to give this problem more attention. We're happy to help if anything needs doing on the Opus side, but since the crash is triggered when Opus calls their code (or, more likely, when Opus calls Windows, which then calls their code), it's a black box to us which we cannot debug.