Right-click drag broken (version 12.19 x64)

On Windows 10, running version 12.19 x64 right-click drag for single files or multiple files only works maybe 1 in 20 times. If I'm patient and keep trying it, it almost always eventually works (occasionally I run out of patience). Left-click drag works every time. It doesn't seem to matter if the drive is magnetic, SSD, or remote.

See attached video showing what it's doing.

Maybe your right mouse button is faulty?

Are you in Details mode or Power mode?

(If you're in Power, try Details.)

This seems to be the most likely.
test anywhere online

I'm a gamer, there's nothing wrong with my Logitech MS Master 2S right-mouse button.


Thanks for the suggestion, I wasn't even aware of "Power mode" and I'm going to have to play with it to see if I like it. I searched and could not find any tutorials or explanation of how Power Mode is better. One thing I can't figure out is any way to clear the selected files. In fact, alt, shift, and control keys don't appear to do anything at all?

But as far as the right-mouse drag goes, it works almost every time in power mode. Occasionally, instead of dragging, it acts like rubber-band left-mouse (meaning it changes the selection of files instead of switching to drop). In those cases when I release the right-mouse button (over an empty space in a directory listing) I get the normal right-click context menu instead of the drop files context menu. Maybe there is something subtle about power view mode that I'm missing (could I be missing the selected row by a hidden pixel line or something)? I'd be happy to do another demonstration video showing what I'm seeing if you think it would help.

It's interesting that the listing mode has such a significant effect on the right-click drag.

OK, this is weird. Since I switched in and out of Power View Mode, the right-click drag is now working 100% in Details mode. I don't know what to make of that. I tried it on large directories, small directories, large and small files, it's working just like it used to. Did I reset something in Dopus when I switched views? I'll have to wait and see if this continues to work over time or if it degrades.

I do use Dopus a lot and often have 6-10 dopus windows open on multiple monitors, plus I often have directories with upwords of 1,000 files in them. I wonder if this is a memory leak issue and the details control will degrade over time... If it starts happening again, I'll try switching in and out of power view and see if that clears it up and I'll report back.

Thanks again,

Power mode isn't really better, it just lets you configure the way the mouse buttons and selection work to be different than the Windows standard (e.g. for people used to other OS or non-standard file managers).

Display mode shouldn't really affect whether RMB drag & drop works, other than that if you were in Power mode by mistake then the RMB action might have been configured to something other than drag & drop. Doesn't sound like that was it, though.

Something that can affect RMB drag & drop is shell extensions other software has installed which adds items to that drop menu. Using ShellExView to look for Drag & Drop Handler, and Drop Handler extensions may reveal some worth disabling to see if they're affecting things. (Best to reboot after disabling them.)

(There are some other things as well, but they'd usually also break LMB drag & drop, so probably aren't relevant here.)


OK, I found the Power Mode Buttons configuration. In case it matters they are set to:
Normal drag select - Immediate action
Context Menu (select) - Show menu
Inline Rename - Disabled

I'll have to play with the settings and see how the view reacts. Thanks!