Right Mouse Button not working

DOpus is a great tool, and i would love to use it, weren't it for a rather consistant bug which has bothered me since the earliest windows version, and which ultimately forced me to not use Dopus.

I've WindowsXP SP2 installed, 512 mb of ram and use a firewall, anti -spy/trojan/virus/rootkit software on a regular basis. As far as i'm aware of, I have none of the above malicious software types installed.

I'm mentioning this because these are the first one I personally would blame for the behaviour i'm going to elaborate on.

After a while of running Dopus, the right mouse button stops working as it should, in version 5 afair, trying to click the RMB for the context menu anywhere in opus resulted in strange things, eg. the button customization started popping up, or something else, but mainly some button customization popped up. And the context menu never showed at all. Not when clicking on drives, folders files or anywhere. Very very frustrating.
The left mouse button still remains functional.

Now with the newest version, this still continues. Whereas now the madness with strange happenings seems to be no longer, the non-working context menu on right mouse button click remains.

It is noteworthy that this only applies to DOpus, everything else remains functional, WE, Winrar whatever, only opus seems affected.

I've tried locating some other reports of this, or possible fixes, but to no avail.
I've tested opus numerous times throughout the years, always trying to get around that particular bug, with many fresh installs of windows in between but after some time i usually started encountering this behavious and stopped trying.

Now with unicode finally supported i want to use Opus desperately, but can't as yet again, RMB clicks are simply not working or doing slightly strange things, eg opening a second tabbed lister or working like a LMB click or something like that.

I'm really wondering why this happens, i do have some suspicions, but until now, i never found the nerve to actually do some elaborate tests and investigations apart from idle googling and other quick'n dirty approaches.

Any help is appreciated.

Hey there... I know it's going to send very generic, but have you always had the same mouse/keyboard... or even system that you've tried running on? I'm just curious if you might have any of the various keyboard/mouse software packages installed from vendors like Microsoft, Logitech, etc etc. I had some strange issue with some intellipoint drivers a while back when I eval'd Dopus 6... where right clicking anything in Opus caused the mouse pointer to veer of in some random direction and ALWAYS bring up the toolbar customization or desktop properties dialog... when I later came back to eval Opus a few months later, I had the same system, but for other reasons (related to some issues with PC games I had been playing) had re-installed my system - MINUS the intellipoint stuff. Food for thought...

hmm, thanks! I never considered that, though it does seem very likely. Well at any rate, I can not work without the intellipoint software, as i assign copy/paste to the two extra buttons, and in general, have a large list of program specific buttonconfigs i'm using, so i would prefer opus being able to work WITH intellipoint rather than without.
Though a friend of Mine who has intellipoint installed as well, same copy/paste config, has had no occurrence of the mentioned problem.
I've used the intellimouse's since almost 6 years or so, at least. pretty much the same for him. In the meantime i've upgraded said driver countless times, and got myself a intellimouse explorer v3 to replace my old v1.

Well, if you're interested... you might consider testing your system 'minus' the intellipoint drivers just to confirm that is what is causing the conflict... at least then GPSoft might have something concrete to go on in order to even try to resolve it. It certainly seems like you'd like to be able to use Dopus... and I can't say I blame you for not being thrilled at the prospect of having to troubleshoot this... if I had the same system nowadays I'd go back to the problems I had to try and help get the thing debugged. But you might be suprised at what problems Greg and Jon wind up being able to fix once they know for sure what the cause is... specially if they can actually reproduce it.

If you're getting weird behaviour when right-clicking files it's probably a context-menu handler doing something strange that upsets Opus but works fine in Explorer. Perhaps it's sending a window message that it uses internally and which Explorer ignores but Opus interprets.

The registry keys mentioned in this thread may help, although since the problem isn't actually causing a crash -- just odd behaviour -- you may find it harder to track down exactly which shell extension is causing the problem:

resource.dopus.com/modules/newbb ... st_id=2484

Let us know if you work out the cause!

Thank you for your insights. I will try to find the cause when I feel ready for it, which might take a while.

I'll definitely report my findings.