Rotating images via EXIF information no longer working

For a long time I've used a feature in dopus that lets me autorotate my images. I use it on hundreds of pictures at a time and it's always been very useful.

Now it doesn't do anything. I don't think I've done anything in dopus settings to break it - but maybe I have?

For the moment I'm having to use jpg autorotate.........

I've attached a picture of the settings window - showing the way I always have it set up for rotating images.

It works in my case (I tested now on latest beta).
Check in preferences if option "Use EXIF information (if present) to auto-rotate images" is turned off, then you'll see is your photo rotated or not.

I always have that option turned off, for thumbnails and viewer, and something else. It's off everywhere in setttings. I hate it as you think your images are correctly rotated until you upload them to some other service.

I am on 12.2. Bought it as soon as it was released.

Can you give us an example JPG with EXIF rotation information that isn't being rotated correctly for you?

How are you launching the conversion dialog? Is it from a custom command/toolbar/menu? If so, please check what the command is and paste the details here.

Well that's strange.

I just took a picture with my phone, checked it needed rotated (it did), and launched exif rotate in my normal way (see below).

I right click on the image (or normally a whole pile of images), select the dopus command "convert image" from the right click menu, and then configure the settings window the way you see in my first post in this thread.

Anyway, it just worked. The picture was taken with my phone. I normally import pictures from my Nikon camera (it is very up to date and definitely embeds exif orientation data in the jpgs.

I've been bringing in lots of pictures after doing work inspections and running dopus autorotate on all of the photos, and it doesn't change a single one.

I've been doing it exactly as listed above. That's how I've always done it and it always worked, until recently.

Maybe I need to go and get that camera and take a bunch of pictures, and try again.

BTW. I made vertical image, then check it with IrfanView, rotate using EXIF option and then re-open the same image in IrfanView. So I check that it works in my case. But of course this is not a solution and personally I don't like if someone says "in my case it works", so I hope your problem will be fixed. I was only want to help (just in case) to check that problem is real in your case.